p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   BOOK: Beginning Ruby on Rails (http://p2p.wrox.com/forumdisplay.php?f=289)
-   -   Scaffolding problem (http://p2p.wrox.com/showthread.php?t=59165)

johnisdumb June 18th, 2007 01:01 AM

Scaffolding problem
 
Everytime I try to run scaffolding (chap 6) weather from the example in the book, or any test for that matter, I get the following output.

Code:

      exists  app/controllers/
      exists  app/helpers/
      exists  app/views/manage
      exists  app/views/layouts/
      exists  test/functional/
  dependency  model
      exists    app/models/
      exists    test/unit/
      exists    test/fixtures/
   identical    app/models/poem.rb
   identical    test/unit/poem_test.rb
   identical    test/fixtures/poems.yml
dyld: ruby can't open library: /usr/local/mysql/lib/mysql/libmysqlclient.15.dylib  (No such file or directory, errno = 2)
Trace/BPT trap

I am running:
Mac OS X 10.3.9
Rails 1.2.3
Ruby 1.8.6
MySQL 5.0.41

any advice as to what I can do?


ciderpunx June 18th, 2007 05:12 AM

In think its cos recent versions of my sql have changed their path from lib/mysql to just lib. A mac friend suggests you open a terminal and type:

Code:

sudo install_name_tool -change /usr/local/mysql/lib/mysql/libmysqlclient.15.dylib \ /usr/local/mysql/lib/libmysqlclient.15.dylib /usr/local/lib/ruby/gems/1.8/gems/mysql-2.7/lib/mysql.bundle
I'm a linux user so I have no idea if this will work or not.

--
Charlie Harvey's website - linux, perl, java, anarchism and punk rock: http://charlieharvey.org.uk

johnisdumb June 18th, 2007 11:19 PM

Thank you, and your friend, I tried it, but it didn't work. It corrects the path, but it still doesn't find the file, which is there. I can open it with textwrangler.

Again, thank you for your help.


johnisdumb June 19th, 2007 10:41 AM

I was able to fix it by uninstalling MySQL 5.0.41 and reinstalling 5.0.3 something. Now it works fine. Accourding to some PHP boards, there is an issue with the paths changing in 5.0.41.

Thanks for all your help..



All times are GMT -4. The time now is 11:35 AM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.