p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   BOOK: Professional Ajax ISBN: 978-0-471-77778-6 (http://p2p.wrox.com/forumdisplay.php?f=244)
-   -   xmlhttp.status = 12031 (http://p2p.wrox.com/showthread.php?t=64782)

Joecicio December 24th, 2007 02:27 AM

xmlhttp.status = 12031
 
I am testing the autosuggest example in chapter 7. At the "requestSuggestions" function:
    oHttp.open("post", "suggestions.php", true);//OK
    OHttp.send -- does not throw an error
    oHttp.readyState == 4 but
    oHttp.status is always 12031
There are lots of forum discussions of this error on other sites but none are helpful. I have tried different ways to address "suggestions.php" but nothing worked. I am using IE7 and IIS
Removed the "echo" statement from suggestions.php and still get a readyState == 4
5.1. Don't know how to tell if the "POST" made it to suggestions.php

joefawcett December 24th, 2007 05:32 AM

Have you tested the web service as a stand alone, without the autosuggest client?

--

Joe (Microsoft MVP - XML)

Joecicio December 26th, 2007 06:02 PM

Not sure I know how to test the service - besides what I'm already doing. I don't have a php debugger so there is no way of telling that the post reaches the target. There are many other people getting this undocumented (microsoft only) error code. Some other sites are suggesting using GET instead of POST - which I am about to try. Also - the xmlhttp object is probably provided by IE7 - it comes directly from the lib provided from the wrox downloads for this book. I will try a non MS browser next.
Quote:

quote:Originally posted by joefawcett
 Have you tested the web service as a stand alone, without the autosuggest client?

--

Joe (Microsoft MVP - XML)


All times are GMT -4. The time now is 05:27 PM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.