p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Apache Tomcat (http://p2p.wrox.com/forumdisplay.php?f=107)
-   -   404 Error's Code on Tomcat/Eclipse (http://p2p.wrox.com/showthread.php?t=72796)

unodellacombriccola February 18th, 2009 05:18 AM

404 Error's Code on Tomcat/Eclipse
 
Hi everybody,
sorry for my english leanguage but I'm an intalian guy.

I've a problem with Tomcat.

Problem:
I've a web application http://localhost:8080/mywebapplication/
if I put in http://localhost:8080/mywebapplicati...hoto/photo.jpg
a photo the resource is not accessible, BUT if I refresh a folder in Eclipse and after I open the link with Firefox it work.
Why????
I hope you understand me.

in italiano.. ;)
Salve a tutti ho un'applicazione già deployata e funzionante al 100%.
Il problema è che dopo un upload di una foto in una determinata directory (sotto webContent/fileUpload) la risorsa non è accessibile (attraverso il browser), ma se vado sotto eclipse e "refresho" la cartella allora va tutto bene. La stessa cosa succede se io "fisicamente" con esplora risorse di WinXp accedo alla directory, copio e incollo una foto, con il browser non è accessibile ma se faccio un reload in eclipse riesco a vederla...mahh!

Best regards...
Grazie a tutti..

iamrakesh22 March 5th, 2009 03:24 AM

I think its clearly a deployment problem, check the war file of your application whether it includes this image or not [You can use winzip or winrar to open it] if not then check the war file generation script. As you said when you refresh the directory the image is available means that eclipse is doing hot deployment, i mean eclipse checks updated files and overwrites the existing deployed files in tomcat.

Hope it gives a way to find your problem!


All times are GMT -4. The time now is 11:46 AM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.