p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   BOOK: Beginning Microsoft Visual Basic 2008 ISBN: 978-0-470-19134-7 (http://p2p.wrox.com/forumdisplay.php?f=403)
-   -   Chapter 16 - Accessing Databases error (http://p2p.wrox.com/showthread.php?t=77473)

ldgotz December 17th, 2009 01:45 AM

Chapter 16 - Accessing Databases error
 
Error message:
Could not retrieve schema information for table or view

i am doing the first part of chptr 16, no code is being written..
pg 546 try it out

I get the above error msg when I try to make the actual connection to the access database.. I can test the connection ok.. I can preview the data ok..
but when I try to populate the datagrid, it is blank...
I have downloaded the northwinds database multiple times...
I created a database - to eliminate the possible of a corrupt downloaded file.. and I get the same error...

Can you please explain how I can correct this error...
I did search the error.. and I can find no exact match. but a few close ones..
and they are all making repairs with lengthy code entries...

on a side note... when I download your chapter 16 code.. it runs...

This would not be funny, but, I am writing NO CODE.. to qoute your book
pg 548
<At this point you have not written a single line of code to achieve these results>

Seeing how I am new to this, I hope I provided enough detailed info to help you arrive at a working conclusion that will help me....

thank you
Larry

bnews987 January 31st, 2010 01:59 AM

can you find a text comparison tool like winmerge(free) and compare your project with the one you downloaded. If you can post the differences we should be able to pinpoint and fix.

ramcdonald72 February 2nd, 2010 11:22 AM

Larry
I have same problem- did you ever solve it?
Bob

bnews987 February 3rd, 2010 01:37 AM

Bob, Can you post your connection string? Bryan

ramcdonald72 February 3rd, 2010 03:22 PM

Bryan
The connection string is:
Provider=Microsoft.Jet.OLEDB.4.0;Data Source= [Data Directory]\Northwind.mdb

When my DataViewGrid wouldn't populate I tried adding my own
record using the control and when I tried to save it
it gave me an exception and said that my Jet.OLEDB.4.0 was not registered-
I don't understand this since I use Access 2007 without any trouble
Thanks for your prompt reply and help
Bob

ldgotz February 3rd, 2010 09:23 PM

sorry for the delay..
my laptop crashed and required parts for repair..
on my laptop, Yes it now works, but only after
a full reload... I am not sure why it failed prior..

I know this is not enough information to resolve this issue..
and it is not the answer I was looking for....

But the reload corrected this issue...

Larry

bnews987 February 4th, 2010 12:46 AM

Bob,

Have you downloaded the code from the wros site? If not, the link is at the top of this post. Try that example and see if it runs. Bryan

ramcdonald72 February 4th, 2010 03:04 PM

Bryan
I downloaded your copy of Northwind Customers DatagridView but when I tried to open the project it gave me the following 2 errors
1- Could not load file or assembly "System.Data.DatasetExtensions, Version=2.0.0.0, Cultural=Neutral PublicKey= b77......89 or one of its dependencies. The system cannot find the file specified.

2- The variable "NorthwindDataSet" is either undeclared or was never assigned.

THanks
Bob
PS- I have worked through the first 15 chaps of your book and think it is great!

bnews987 February 6th, 2010 01:18 AM

Do you have .net framework 2.0 installed? Try to install that. You me be able to go to add reference and remove the reference to that version and add the reference to whatever version you had. That code definintely works so something is missing on your machine. Are you running windows 7?


All times are GMT -4. The time now is 07:46 AM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.