p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Dreamweaver (all versions) (http://p2p.wrox.com/forumdisplay.php?f=58)
-   -   IIS and Dreamweaver MX (http://p2p.wrox.com/showthread.php?t=7754)

Andrew Antoniak December 30th, 2003 06:11 PM

IIS and Dreamweaver MX
 
I have just started to learn Dreamweaver and am reading the Wrox publication "Beginning Dreamweaver MX"

I have installed DW MX successfully, and have installed Microsoft's IIS Web Server. The book recoomends you test the installation to ensure the ASP is running, by opening the web browser and typing http://localhost/localstart.asp into the address box. Whenever I do this I receive the following message:-


" The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: http://localhost/localstart.asp

The following error was encountered:

Unable to determine IP address from host name for localhost
The dnsserver returned:

Name Error: The domain name does not exist.
This means that:

 The cache was not able to resolve the hostname presented in the URL.
 Check if the address is correct.

Your cache administrator is webmaster.



--------------------------------------------------------------------------------
Generated Tue, 30 Dec 2003 21:47:30 GMT by proxy (Squid/2.4.STABLE7) "

I have checked Admin Tools / Services in Windows XP ( I have Windows XP Pro) and have confirmed that the status for the World Wide Web Publishing item is showing as "Started".

Is there anything else I can do to get the thing working?????






Imar December 30th, 2003 07:14 PM

Hi there,

Hmmm, odd. Usually localhost should map to your local machine. What kind of DNS Service are you running?

You may want to try 127.0.0.1 instead (the IP address of the local machine). What happens when you ping 127.0.0.1? Or browse to http://127.0.0.1/localstart.asp ?

Cheers,

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.

Andrew Antoniak December 31st, 2003 07:43 AM

Good Morning Imar,

My service is provided by Frontier, and I am connected at home to my office 8 miles away so I can pick up my Outlook emails from there.

I tried pinging 127.0.0.1, and received a positive message that nothing was lost in the loop. However when I browsed to
http://127.0.0.1/localstart.asp I first received a message the page could not be displayed:-

"The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.

--------------------------------------------------------------------------------

Please try the following:

Open the 127.0.0.1 home page, and then look for links to the information you want.
Click the Refresh button, or try again later.

Click Search to look for information on the Internet.
You can also see a list of related sites.

HTTP 500 - Internal server error
Internet Explorer"
__________________________________________________ ________________________________

but then having tried it again (by clicking on the link in your email) I received the following message:

"You are not authorized to view this page
You do not have permission to view this directory or page using the credentials you supplied.

--------------------------------------------------------------------------------

Please try the following:

Click the Refresh button to try again with different credentials.
If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the 127.0.0.1 home page.
HTTP 401.2 - Unauthorized: Logon failed due to server configuration
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Background:
This is usually caused by a server-side script not sending the proper WWW-Authenticate header field. Using Active Server Pages scripting this is done by using the AddHeader method of the Response object to request that the client use a certain authentication method to access the resource.

More information:
Microsoft Support "

Does this help?

Regards,
Andrew Antoniak



Imar December 31st, 2003 09:15 AM

Hi Andrew,

Are you running a firewall? Maybe some piece of software is blocking access to your Web server.

Take a look here: http://p2p.wrox.com/topic.asp?TOPIC_ID=1839 to find out how you can turn off Friendly HTTP error messages. Then reload the page and you'll get a more descriptive error message.

Alternatively, disconnect from the Internet and try again. Does your computer have a network card installed?

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.

Andrew Antoniak December 31st, 2003 12:48 PM

Hi Imar,

I have turned off the friendly messaging, and now when I type in http://127.0.0.1/localstart.asp the following message appears:

"The specified module could not be found. "

Does this suggest some program is blocking access?

Regards,
Andrew




Imar December 31st, 2003 02:18 PM

Hi Andrew,

To be honest, I don't know. If you search Google for this error message you'll see a couple of hits, but I don't know if they apply to your situation.

Are you running a firewall? Did you try to disable it? Does your computer have a network card? Was that card installed when you installed IIS?

I am off now, celebrating New Year. Hope it's going to work out for you. Don't forget to party tonight ;)

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.

Andrew Antoniak December 31st, 2003 02:24 PM

Hi Imar,

I have loaded Netscape and get exactly the same message as with IE - "The specified module could not be found". Additionally it seems that Netscape cannot make contact with the server.

You asked whether there was a firewall, and I am pretty confident one has been installed by our network administrator following the introduction of Broadband. Is there any way of checking whether the firewall is causing the problem and if so how the problem is being caused?

Regards,
Andrew


Imar December 31st, 2003 02:33 PM

It looks like an IIS error to me, so it makes sense that the error message in Netscape is the same as in IIS.

I don't think a corporate firewall would matter much. But one on your local machine can really mess things up.

How is your network connection setup? Does the computer have a network card? (I think this is the third time I am asking that question). Are you using a Dial Up connection without a network card?

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.

Andrew Antoniak January 5th, 2004 06:53 AM

Imar,

My PC does have a network card. I do not dial as I use a router using a gateway, sub net, dns, and an ip range for routing.

Regards and Happy New year,
Andrew Antoniak




stu9820 January 5th, 2004 11:11 AM

Have you tried to uninstall IIS and reinstall it?



All times are GMT -4. The time now is 01:22 PM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.