p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   BOOK: Beginning ASP.NET 4 : in C# and VB (http://p2p.wrox.com/forumdisplay.php?f=560)
-   -   Can't drag controls onto Design View page (http://p2p.wrox.com/showthread.php?t=81841)

Zookeeper December 8th, 2010 06:12 PM

Can't drag controls onto Design View page
 
I'm just starting with the book and am stumped by a problem in chapter 1 (the "Try it out: Creating Your First ASP.NET Web Page"). I followed the directions exactly for steps 1 - 7. The only difference is I changed where the project folder is stored but that should not matter. On Step 8, when I try to drag TextBox and Button controls into the div area, the mouse pointer turns into a negation symbol (a circle with a slash through it) and I cannot drag & drop the controls. I'm definitely in Design View.

This must be something simple that I'm overlooking. Can someone help me out?

I'm using Visual Studio 10 Ultimate on a Windows XP system.

Thanks!

Zookeeper December 8th, 2010 06:25 PM

OK, not sure what this fixed the problem but shutting down VS, restarting it and re-opening my project fixed the problem. Still, if anyone knows what the original cause might have been please chime in.

Zookeeper December 11th, 2010 01:33 AM

I'm seeing this behavior yet again. There must be something wrong with my system. In this case, I was performing the Try it Out exercise starting on page 49. I created the first aspx page, added the label & code and ran it in a browser. I then added the second page (Inline.aspx) and was unable to add a label control (or any other). I tried adding the aspx code instead of using dragging and dropping. I pasted the following into the Inline.aspx file between the two div tags:

<asp:Label ID="Label1" runat="server" Text="Label"></asp:Label>

When I switched to design view, instead of the label I saw the following error message:

Error creating control: hresult e_fail has been returned from a call to a com component

I've Googled this and not found a solution. It seems this happens when I run a project and then try to add controls to it afterword. If I save the project, close and then reopen VS10 I'm able to add controls again.

This is going to get REAL tedious if I'm going to have to close and reopen Visual Studio after ever test run of a project. I hope someone here can give me a tip as to what the problem is.
[:confused:]

Imar December 11th, 2010 06:09 AM

Hi there,

That doesn't sound right ;-( Have you tried repairing or reinstalling Visual Studio? Also, do you have any add-ins or extensions installed and active that may be causing thhis issue? If so, try disabling them and see if that works.

Cheers,

IImar

Zookeeper December 11th, 2010 12:01 PM

Thanks for the reply, IImar! I've tried deleting the ProjectTemplatesCache and running "devenv /setup" to rebuild the cache (idea from http://forums.asp.net/p/1607965/4104640.aspx) but the problem continues.

I haven't tried doing a repair or uninstall but will look at this later today or tomorrow.

The only add-in I have is VMware Virtual Debugger (I have VMware Workstation 7 installed on my development machine). I removed it from the Add-Ins list but the problem persists...

Zookeeper December 13th, 2010 02:08 AM

OK, I tried a repair install. As a result I was no longer able to run my site (open in browser). Finally tracked it down to my firewall (ESET Smart Security) and managed to get the firewall to allow the ASP.NET web server to work. But the original problem persists.

The only work-around I seem to have is to close and re-open the project every time this happens. Not a very satisfactory solution but I'm afraid there won't be any magic fix for this.

Imar December 13th, 2010 03:41 AM

Quote:

Not a very satisfactory solution
Pfff, indeeed.... ;-)

You could file a bug report on http://connect.microsoft.com

Cheers,

Imar

Zookeeper December 13th, 2010 09:42 AM

Quote:

Originally Posted by Imar (Post 266498)
You could file a bug report on http://connect.microsoft.com

I've just tried. After 30 minutes of repeatedly being told to first, sign up for a bloody Windows Live ID (used to have one but they seem to have forgotten about it) I signed up for a new one and started the process over. It then told me I needed to open a Microsoft Connect account. So I did. And started the process over once again. And am now AGAIN told that I need to open a Microsoft Connect account to continue. Rinse, wash, repeat.

At this point I'm feeling pretty much like a rat in a maze that probably doesn't really have any cheese at the end. I give up. If I made it this hard for my customers to contact me about problems with my software... well... I guess I'd not be bothered with supporting my customers.

None of the above is your fault of course. Thanks for responding. Guess I'll wait for Visual Studio 11.

Zookeeper December 23rd, 2010 12:31 AM

Quote:

Originally Posted by Imar (Post 266498)
You could file a bug report on http://connect.microsoft.com

Tried again today and this time the site let me in and didn't put me on a registration merry-go-round. I submitted the bug (here's the link). I'll post back if I get any help. Meanwhile I guess I'll have to install to a different computer for my web development.

:-(

Imar December 23rd, 2010 04:08 AM

Let's hope they can work with you and figure out what the problem is.

Cheers,

Imar


All times are GMT -4. The time now is 11:19 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.