p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   Classic ASP XML (http://p2p.wrox.com/forumdisplay.php?f=69)
-   -   msxml3.dll (0x800C0005)he system cannot locate (http://p2p.wrox.com/showthread.php?t=8761)

shubhad January 30th, 2004 02:42 AM

msxml3.dll (0x800C0005)he system cannot locate
 
I am using httprequest object to acces other sites but
I can't ,,,, it may be because of security..

This is example code which i got from net.. if i try to execute i am
getting error as msxml3.dll (0x800C0005)
The system cannot locate the resource specified.
so please help in solving this problem


  ' Create an xmlhttp object:
  Set xml = Server.CreateObject("Microsoft.XMLHTTP")
  ' Or, for version 3.0 of XMLHTTP, use:
  ' Set xml = Server.CreateObject("MSXML2.ServerXMLHTTP")

  ' Opens the connection to the remote server.
  xml.Open "GET", "http://www.4Guysfromrolla.com/", False

  ' Actually Sends the request and returns the data:
  xml.Send

  'Display the HTML both as HTML and as text
  Response.Write "<h1>the HTML text</h1><xmp>"
  Response.Write xml.responseText
  Response.Write "</xmp><p><p><h1>the HTML output</h1>"

  Response.Write xml.responseText


  Set xml = Nothing

so please help me.... while sending the request it is givng me problem at http.send()
              Please put some light on this
thanks'
shubha


carlhancock February 4th, 2004 11:23 AM

We are having the *EXACT* same problem.

We have been using a similar setup for almost a year now.

And on Monday, we started noticing the error you are referring to.

We can't figure out what is going on. The code hasn't change. Nothing to my knowledge has changed, it just returns the error message:

msxml3.dll (0x800C0005)
The system cannot locate the resource specified.

When you try to execute the send command.

Can anyone out there help?


fmarrone March 10th, 2004 05:33 PM

Has anyone ever figured out why they were receiving this error?


artura September 2nd, 2004 01:58 PM

Please check this link - http://support.microsoft.com/?kbid=843499. May be the dll registration is a problem.


monkeyButt December 3rd, 2004 09:48 AM

I was getting this error on a production server - it would spontaneously appear every 2 or 3 weeks, at which point the web app could no longer parse xml. Googling didn't turn up much, just other people asking how to get rid of this error, some with situations similar to mine. The only fix I had found was to reboot the server.

About a month ago, it dawned on me that the XML objects in my ASP code might not be freed - so perhaps the error was due to a memory problem? I dove into the code and confirmed the problem.

set xmlObj = Nothing

Haven't seen the error in 4 weeks...


michail1 April 16th, 2005 01:25 AM

Been searching on this for days.

I am confirming that is has something to do with a firewall.

I have access to 4 servers. 2 running Windows 2000 SBS (small business server) with ISA firewall - 2 nics. 2 servers with regular 2000 server.

The 2 with 2k server run great. No problems.
The 2 with SBS both have problems giving the c0005 error.
If you run your ASP page to do your request within the server, then it works. Not externally though. The error is always at the .send command.



http://www.KoltenW.com

dennison October 19th, 2005 01:08 AM

Hi ,
are you uisng some proxy for connecting to internet.

if yes use the following code and try

Set objWinHttp = server.CreateObject("WinHttp.WinHttpRequest.5.1")
objWinHttp.Open "POST", "http://www.4Guysfromrolla.com/"
objWinHttp.SetProxy 2,"18.87.8.3:1991"
comment 18.87.8.3 is the ip and 1991 is the port number
objWinHttp.SetRequestHeader "CONTENT-TYPE","application/x-www-form-urlencoded"
objWinHttp.SetTimeouts 30000, 30000, 30000, 30000
objWinHttp.Send m_cPostBuffer
strHTML = objWinHttp.ResponseText
response.write strHTML
Set objWinHttp = Nothing

but you need to register winhttp.dll.
It may be already in your system, else search in google you'll get this DLL

Denny

lancewelker December 3rd, 2005 01:09 AM

This thread describes the exact problem I'm having with my Hosting provider. I'm hosting a Web site with XO Communications (cnc host) and attemting to use Payment Data Transfer services with Paypal. The communication between PayPal and my Web site requires the xmlHTTP object and the .Send function - so far I can't get XO Comm. to tell me Yes or No if this should work, but I've been trying for days to figure out what the heck is going on. I'm getting that msxml3.dll error "server cannot find resources specified" on the command line where my code uses the .Send function. These guys at XO have no clue what to say about this xmlHTTP object. Can anyone out there help me troubleshoot this? Do you know if there is a reason why the hosting company wouldn't allow me to use the xmlHTTP and .Send? Thanks. Lance


dennison December 16th, 2005 07:54 AM

instead of xmlHTTP , is it possible to use WIn32 Internet functions
if yes then u may be able to post data using the HttpSendRequest()


go thru this url

http://www.graphcomp.com/info/specs/ms/inetr001.htm

hadasc March 11th, 2007 03:49 PM

I got that too.
I noticed that it happens when my url or body parameter exceeded 255 bytes.

Check your cases it might be the same.
anyway I still need help with that thing :-)

[:X]


All times are GMT -4. The time now is 02:17 PM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.