p2p.wrox.com Forums

p2p.wrox.com Forums (http://p2p.wrox.com/index.php)
-   BOOK: Professional XMPP Programming with JavaScript and jQuery (http://p2p.wrox.com/forumdisplay.php?f=542)
-   -   Chapter 7: Dig Problem with Second Request (http://p2p.wrox.com/showthread.php?t=89046)

David Sides December 31st, 2012 12:56 AM

Chapter 7: Dig Problem with Second Request
 
Enjoying working through the book. Thanks for writing it!

Regarding Dig in Chapter 7: The first disco request seems to work fine, but when I click on the conference.jabber.org reference in the outline, it highlights and I receive a 404 not found error. A screen shot with the HXR requests logged in Chrome are visible at:

http://mazedeck.com/xmpp/Dig-Problem.png

Any suggetions? I downloaded the source directly from the book site and modified dig.js to use bosh.metajack.im:5280/xmpp-httpbind. I am not using the flXHR library. Eventually targeting mobile so want to use CORS.

Thanks.

David

David Sides December 31st, 2012 01:15 AM

Github source still exhibits problem
 
I just tried the dig.js from github instead of the book site and that didn't fix the problem.

metajack December 31st, 2012 07:18 PM

The 404 is not related to your XMPP traffic. Something is causing the session manager to terminate your session. You'll need to look at the wire traffic to determine what's wrong.

David Sides January 2nd, 2013 12:10 AM

Too Many Rooms?
 
Thanks for the quick reply and the pointer. Firebug was helpful in looking at the post response.

When I run dig against other XMPP servers it seems to work fine including returning lengthy lists of rooms. Looking at the response to the request for items at conference.jabber.org it appears to blow up. Maybe the list of rooms is too long or contains something that's a problem for dig. I'm not going to worry about it further since it doesn't apply to my challenge at this point.

Thanks again. -David

metajack January 2nd, 2013 04:57 PM

I think you're right that it's a stanza size issue. I think many servers cut it off at 10k, and they probably do this by terminating the connection. It seems a bit weird that it would terminate your connection instead of the s2s one, but I can imagine it happening.


All times are GMT -4. The time now is 07:58 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.