Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Search Forums
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Welcome to the p2p.wrox.com Forums.

You are currently viewing the section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Showing results 1 to 25 of 131
Search took 0.02 seconds.
Search: Posts Made By: Neal
Forum: XSLT December 4th, 2019, 09:29 AM
Replies: 3
Views: 988
Posted By Neal
Thanks Michael, I'm using XMLSpy 2017...

Thanks Michael,
I'm using XMLSpy 2017 Professional. I hope I understand your reply. Here is the xslt code including referenced namespaces.


<?xml version="1.0" encoding="UTF-8"?>...
Forum: XSLT December 3rd, 2019, 01:28 PM
Replies: 3
Views: 988
Posted By Neal
Adding multiple namespaces to root element

Hi,

version 1.0

I have a requirement to output a root element that contains 2 namespaces. Neither of the namespaces are contained within the input xml. The desired output is :

<Document...
Forum: XSLT May 24th, 2018, 06:36 AM
Replies: 4
Views: 2,585
Posted By Neal
Thank you both... You both helped me...

Thank you both...

You both helped me overcome the main problem. I still have an issue with the 'MessageParts' output. Please can either of you assist?

Michael - I have updated using your advise...
Forum: XSLT May 24th, 2018, 04:56 AM
Replies: 4
Views: 2,585
Posted By Neal
Copy ALL elements except one

Hi,
I have an XML file that I need to update using XSLT. The update is on 1 field only (DocumentDestinationPartner). The rest of the XML should remain the same.

Original XML file

<?xml...
Forum: XSLT June 24th, 2014, 08:55 AM
Replies: 1
Views: 724
Posted By Neal
Issue retreiving values where parent and child have same namespace

Hi,

I have an issue retreiving values where parent and child have same namespace. I am using xslt version 1.0 and evaluating using xmlspy.

I need to read the value of the ItemId and Price...
Forum: XSLT June 10th, 2010, 12:13 PM
Replies: 3
Views: 10,067
Posted By Neal
You're right, I was. Thanks!!

You're right, I was.

Thanks!!
Forum: XSLT June 10th, 2010, 11:23 AM
Replies: 3
Views: 10,067
Posted By Neal
Recursive loop to concatenate values

version 1.0 (using Altova xml spy)

Hi,

I have an xml sheet that contains several repeating nodes that contain different values. I am using a recusive template within my xslt sheet but can't...
Forum: Access VBA February 26th, 2010, 04:07 AM
Replies: 1
Views: 2,862
Posted By Neal
Hi again, I finally worked it out... it was...

Hi again,

I finally worked it out... it was simple (these things usually are). Firstly:

strPeriodParam = "*"

Then, within the Query, I typed the following in the Criteria row of the...
Forum: Access VBA February 25th, 2010, 04:41 PM
Replies: 1
Views: 2,862
Posted By Neal
Use of Wildcard as parameter in query

Hi,

I'm using Access 2003 and am passing a parameter in a query which is used as the record source of a report.

One of the options a user can select is 'ALL' which passes the 'Like *' code to...
Forum: Excel VBA October 19th, 2009, 12:53 PM
Replies: 1
Views: 1,039
Posted By Neal
I think I've found the answer. It should perhaps...

I think I've found the answer. It should perhaps be:

=IF(H7<>"",INDEX(Setup_Tables!I5:I54,MATCH(H7,Setup_Tables!H5:H54,0)),1)

Thanks anyway.
Forum: Excel VBA October 19th, 2009, 12:22 PM
Replies: 1
Views: 1,039
Posted By Neal
Cell formula query

Hi,

I need to build a formula in a column I on Account_Setup worksheet within my workbook.

Firstly, it is based on whether Column H on the same sheet is <> blank "" (if Column H = blank then...
Forum: XSLT October 6th, 2009, 07:41 AM
Replies: 2
Views: 589
Posted By Neal
Thanks for the very prompt reply. I knew it was...

Thanks for the very prompt reply. I knew it was something simple,
Forum: XSLT October 6th, 2009, 07:31 AM
Replies: 2
Views: 589
Posted By Neal
Return LineNumber Attribute value

xslt 1.0

Hi,

I am having problems returning the LineNumber value (01) as a varible from the following code example.


<?xml version="1.0" encoding="UTF-8"?>
<F4FInvoice...
Forum: Excel VBA September 25th, 2009, 06:45 AM
Replies: 1
Views: 1,228
Posted By Neal
Form name as variable

Hi,

I have a routine that is used within several forms and I would like to contain it in a separate module which is referenced by each form.to cut down on coding.

Is there a method that I...
Forum: Excel VBA September 24th, 2009, 05:29 AM
Replies: 0
Views: 4,376
Posted By Neal
Forms - VB Editor Title Bar reference

Excel 2003

Hi,

Firstly, I hope that this thread is positioned in the correct forum...

I inherited a large excel workbook that was prone to 'crashing' but after some recent TLC, I have...
Forum: Excel VBA September 22nd, 2009, 06:56 AM
Replies: 1
Views: 2,438
Posted By Neal
return recordset using 'Like' Operator

Using excel 2003

Hi,

I'm trying to return a recordset using the 'LIKE' operator. In the example below, strFilter is a textbox value.


rs.Open "SELECT * FROM qryAccountSetup WHERE...
Forum: Excel VBA September 9th, 2009, 09:14 AM
Replies: 3
Views: 3,393
Posted By Neal
Hi, I do load the basic combobox controls when...

Hi,
I do load the basic combobox controls when I initiate the form.

I'm NOT loading the controls when I click. As per the original posting: .
This is the case for ALL controls that are...
Forum: Excel VBA September 9th, 2009, 05:39 AM
Replies: 3
Views: 3,393
Posted By Neal
Form ComboBox AddItem load is slow

Excel 2003

Hi,
I am using the following example code to load various combo-boxes on an excel form. The connection (co) is to an Access back-end database (Set co = New ADODB.Connection).
Each...
Forum: Access VBA July 27th, 2009, 06:00 AM
Replies: 0
Views: 857
Posted By Neal
Update field with Aggregate Error

Hi,

I have an Access 2003 table that contains 2 fields:

AgeInDays (data type is double but which are whole numbers from 0 onwards)
WeightInKg (Data type is double with default as 0)

I...
Forum: XSLT May 27th, 2009, 12:31 PM
Replies: 1
Views: 684
Posted By Neal
Incorrect Namespace output

Hi,

I am referencing the following namespaces in the top of my XSLT and am having difficulty getting the correct output further into my code.

XSLT NS references

<?xml version="1.0"...
Forum: XSLT March 17th, 2009, 07:36 AM
Replies: 1
Views: 787
Posted By Neal
Using non-literals in literal element structure

xml version="1.0"

Hi,

When saving the xslt file (below), it appeared easier to code using literal result elements rather than the xsl:element approach.

I found this was perhaps due to...
Forum: XSLT March 4th, 2009, 07:27 AM
Replies: 1
Views: 978
Posted By Neal
Outputting a Namespace as an attribute

Hi,

I'm using version 1.0 and Altova XMLSpy for validation.

When attempting to output the following code, I recieve the 'Undefined Namespace Prefix' message (i.e. 'xmlns:' in the first...
Forum: XSLT February 16th, 2009, 10:27 AM
Replies: 7
Views: 1,016
Posted By Neal
Ok, so I've amended my code to include the...

Ok, so I've amended my code to include the suggested line from Martin...

Notice that I've altered the <F4FDeliveryNotification> line to include the 'DeliveryNoficiationType' and 'DocumentType'...
Forum: XSLT February 16th, 2009, 08:38 AM
Replies: 7
Views: 1,016
Posted By Neal
Thanks, Believe it or not, I did try this...

Thanks,

Believe it or not, I did try this earlier. However, the problem is that it appears all of my subsquent code (I only displayed a small section above) now needs to change.

For example,...
Forum: XSLT February 16th, 2009, 08:03 AM
Replies: 7
Views: 1,016
Posted By Neal
xmlns as an attribute

xslt version 1.0

Hi,

I know that there is a problem when defining 'xmlns' as an attribute. But is there a work-around?

Here is my code example...


<?xml version="1.0"...
Showing results 1 to 25 of 131

 


All times are GMT -4. The time now is 02:43 PM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.