Wrox Programmer Forums
|
Access Discussion of Microsoft Access database design and programming. See also the forums for Access ASP and Access VBA.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Access section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old May 17th, 2004, 09:11 AM
Authorized User
 
Join Date: Jun 2003
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Default Filtering Subform Problem

Hello :D

I have a small problem. I have three Access forms one is the main form(frmAgreements) which has two command buttons. Each command button opens a form which is linked by the field AgreementNo. One of the forms (frmTasks) works great when the button is clicked it only displays the records pertaining to the Agreement No selected. The second form (frmInvoices) however does something quite funky. The second form has a subform. When I am in the main form (frmAgreements)and I click the button to go to the second form(frmInvoices) it does filter the records correctly on both the frmInvoices and subform, but I want one the main field of the subform which is the InvoiceNo to display automatically. I went to design/view of the subform then I went to default view and put [Forms]![frmInvoices]![InvoiceNo] and then when I go back to the Invoice Form it tells me it cannot perform action at this time. Then it freezes the whole db. Any suggestions? Thanks you

slypunk
__________________
slypunk
 
Old May 19th, 2004, 06:46 AM
Authorized User
 
Join Date: Jun 2003
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can someone please help me on this I am still stuck.

Thanks

slypunk
 
Old May 19th, 2004, 06:51 AM
Friend of Wrox
 
Join Date: Jun 2003
Posts: 1,151
Thanks: 2
Thanked 14 Times in 14 Posts
Send a message via ICQ to SerranoG Send a message via AIM to SerranoG
Default

How about Forms.frmInvoices.form.InvoiceNo ?



Greg Serrano
Michigan Dept. of Environmental Quality, Air Quality Division
 
Old May 19th, 2004, 07:31 AM
Authorized User
 
Join Date: Jun 2003
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
quote:Originally posted by SerranoG
 How about Forms.frmInvoices.form.InvoiceNo ?



Greg Serrano
Michigan Dept. of Environmental Quality, Air Quality Division
Yeah I tried that and it gave me a #Name? error. I also did Forms.frmInvoices.InvoiceNo and that gave me the same error too.:(

slypunk
 
Old May 19th, 2004, 10:22 AM
Authorized User
 
Join Date: Jun 2003
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the message I receive when I use Forms!frmInvoices!InvoiceNo as the default value in the design view of the subform.
It tells me "You can't carry out this action at the present time."
I just have to fix this problem before placing on the server for users to start utilizing it. Any help I would greatly appreciate.

slypunk





Similar Threads
Thread Thread Starter Forum Replies Last Post
filtering records on subform from an unbound combo jd_erd Access 3 February 12th, 2007 11:21 PM
Problem Filtering Morteza_M Pro VB Databases 2 January 23rd, 2007 08:12 AM
Filtering Dataview [Strange Problem] anup_daware ADO.NET 1 August 8th, 2006 07:09 AM
email filtering problem sanjeewa131 C# 2005 0 July 28th, 2005 06:16 AM
Ado Recordset Filtering problem abumishal Access VBA 0 March 30th, 2004 01:11 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.