Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Microsoft Office > Access and Access VBA > Access
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Access Discussion of Microsoft Access database design and programming. See also the forums for Access ASP and Access VBA.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Access section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old December 2nd, 2004, 05:57 PM
ea ea is offline
Registered User
 
Join Date: Nov 2004
Location: New York, NY, USA.
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default ADP VERY SLOW WITH SUBFORMS HELP!

Hi,

Does anyone know why an .ADP report with three subreports would take over two minutes to load??? I've got 3 more subforms to add and I'm afraid the report will be unusable.

Some specs:

Two of the subforms are views linked by master child relationship.
One of the subforms is a stored procedure using input parameters.
There's not that much data to filter in either the views or the sp (500 records is the largest view)
The there are 4 input parameters on the sp, two being supplied by an open form and two by the main report.

Any ideas???

Yesterday, the thing was still trying to load after 15 minutes before I stopped it. Today, it's loading in about 2 and a half.

I'm using Access 2003 connected to SQL 2000 Desktop Engine. I'm on a stand alone machine.

Any help would be greatly appreciated.

Thanks,
ea



Reply With Quote
  #2 (permalink)  
Old December 3rd, 2004, 02:53 PM
Friend of Wrox
Points: 9,611, Level: 42
Points: 9,611, Level: 42 Points: 9,611, Level: 42 Points: 9,611, Level: 42
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2004
Location: Washington, DC, USA.
Posts: 3,069
Thanks: 0
Thanked 10 Times in 10 Posts
Default

No ideas, other than repair and compact database. I always set my access databases to compact on close to keep the speed up. I hope this helps.


mmcdonal
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Subforms 150563a Access 1 June 29th, 2007 04:57 AM
subforms ajmil11 Access 2 January 19th, 2006 11:16 PM
using ADP with subreports very slow help!!! ea SQL Server 2000 3 December 6th, 2004 11:33 AM
Subforms V Access VBA 1 April 21st, 2004 11:48 AM



All times are GMT -4. The time now is 05:42 PM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.