Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Microsoft Office > Access and Access VBA > Access
Password Reminder
Register
| FAQ | Members List | Search | Today's Posts | Mark Forums Read
Access Discussion of Microsoft Access database design and programming. See also the forums for Access ASP and Access VBA.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Access section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old September 17th, 2006, 05:47 PM
Friend of Wrox
 
Join Date: Mar 2004
Location: Yorba Linda, California, USA.
Posts: 217
Thanks: 0
Thanked 1 Time in 1 Post
Default Forms and reports not flowing


I am having a problem with forms or reports that are launched not displaying in front of other forms on the screen.

Example: main switchboard launches, from it subswitchboard launches. If I launch a form from the subswitchboard, some of the forms do not appear "on top" (They appear either behind the subform or behind the form that launched them.) The same occurs with some other data entry forms (forms launched from the form "go behind" the form. I realize I can use pop-up = true and Modal for the LAST form, but that is not helping on the forms in between. (I really do not want a pop-up or modal submenu.) I am closing out some of the sub-menus as they are no longer needed.

Is there another property I can use to set the launching form on top?
All suggestions appreciated.

Thanks,

Loralee


Reply With Quote
  #2 (permalink)  
Old September 19th, 2006, 06:44 AM
Friend of Wrox
Points: 9,611, Level: 42
Points: 9,611, Level: 42 Points: 9,611, Level: 42 Points: 9,611, Level: 42
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2004
Location: Washington, DC, USA.
Posts: 3,069
Thanks: 0
Thanked 10 Times in 10 Posts
Default

The only thing I can think of is that you are setting the focus with code on the forms, and this focus is preventing the report from taking focus.

As a kludge, you could have an event when the report loads to minimize the launching form, and then on close, restore the launching form?

HTH

mmcdonal
Reply With Quote
  #3 (permalink)  
Old September 27th, 2006, 01:53 PM
Friend of Wrox
 
Join Date: Mar 2004
Location: Yorba Linda, California, USA.
Posts: 217
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks, the only place I've set focus (via object.setfocus is to try to solve the issue on load. I'll take another look through. I'll try your suggestion.

Thanks-


Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing Reports From Forms Brendan Bartley Access 1 June 30th, 2006 07:35 AM
Crystal reports and Sub Forms saili_sheth Crystal Reports 0 January 5th, 2005 01:19 PM
How to create/design reports with crystal reports BassmaniaQ Crystal Reports 0 December 14th, 2004 04:58 AM
Link to JPG images to use in forms and reports bmurrin Access 6 December 10th, 2003 11:19 PM



All times are GMT -4. The time now is 08:49 AM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.