Wrox Programmer Forums
Go Back   Wrox Programmer Forums > Microsoft Office > Access and Access VBA > Access
| Search | Today's Posts | Mark Forums Read
Access Discussion of Microsoft Access database design and programming. See also the forums for Access ASP and Access VBA.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Access section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old October 11th, 2006, 07:23 AM
Registered User
 
Join Date: Oct 2006
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Undefined function 'Left' in expression

Hi...I am getting the above error on a users computer.

I am running Access 2002 and they are running 2003.

The problem comes when running a query to trim off the double quotes off the end of a column (if they are there). Everytime I run this query on my pc it works fine, but every time the user runs it they get the above error.

I have looked at the following threads, but I still can't seem to figure it out:

I am not an Access developer by any stretch of the word and this just got 'dumped' in my lap.

Please Help...

[Edit]
I found and selected the Utility.mda. I'm sending the new database to the user to see if that fixes it (unfotunately we are a couple thousand miles apart so troubleshooting is.......interesting.
 
Old October 11th, 2006, 08:41 AM
Registered User
 
Join Date: Oct 2006
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The utility.mda didn't seem to work. The user is getting the same error.

When I try to walk them through the steps to make sure that the Utility.mda is selected they get the following error:

Microsoft Office Access
Your Microsoft Office Access database or project contains a missing or broken reference to the file 'wdtlog.ocx' version 1.1.
 
Old October 11th, 2006, 01:14 PM
Registered User
 
Join Date: Oct 2006
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Looks like that wdtlog.ocx error could have been because I have SAP loaded and the user doesn't. I unchecked that Reference...

 
Old October 12th, 2006, 06:49 AM
Friend of Wrox
Points: 9,611, Level: 42
Points: 9,611, Level: 42 Points: 9,611, Level: 42 Points: 9,611, Level: 42
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2004
Location: Washington, DC, USA.
Posts: 3,069
Thanks: 0
Thanked 10 Times in 10 Posts
Default

When you uncheck the reference in your application, doe sit still work? If so, uncheck the reference and send them a new copy of the app without the reference. That error would only be thrown when the app was opening, not on the query though. Is that what is happening?


mmcdonal
 
Old October 23rd, 2006, 10:48 AM
Registered User
 
Join Date: Oct 2006
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, that worked...took a while for me to fumble through though....





Similar Threads
Thread Thread Starter Forum Replies Last Post
Undefined function 'Left' in expression Morris Access 13 July 23rd, 2008 02:07 AM
undefined function vurtman ASP.NET 1.0 and 1.1 Basics 8 October 4th, 2004 01:32 PM
Undefined function dhborchardt Classic ASP Databases 0 June 7th, 2004 03:31 PM
Undefined functin left greenfish Access 2 March 24th, 2004 11:51 AM
undefined function: mysql_connect() shabboleth Beginning PHP 2 September 18th, 2003 05:09 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.