Wrox Programmer Forums
|
Apache Tomcat General discussion of the Apache Tomcat servlet container. For discussions specific to the Professional Apache Tomcat book, please see the book discussion forum for that book.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Apache Tomcat section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old December 18th, 2005, 12:51 PM
Registered User
 
Join Date: Dec 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default server fails to start

i am try to deploy a simple application on
apache tomcat 5.0.
the server is giving me following error.

Catalina.start: java.lang.ClassNotFoundException: org/apache/catalina/mbeans/ServerLifecycleListener
java.lang.ClassNotFoundException: org/apache/catalina/mbeans/ServerLifecycleListener
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:164)
    at org.apache.catalina.util.xml.ObjectCreate.start(Xm lMapper.java:616)
    at org.apache.catalina.util.xml.XmlMapper.matchStart( XmlMapper.java:412)
    at org.apache.catalina.util.xml.XmlMapper.startElemen t(XmlMapper.java:91)
    at org.apache.xerces.parsers.AbstractSAXParser.startE lement(Unknown Source)
    at org.apache.xerces.parsers.AbstractXMLDocumentParse r.emptyElement(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanStartElement(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl$FragmentContentDispatcher.dispatch(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanDocument(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
    at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
    at org.apache.xerces.parsers.AbstractSAXParser.parse( Unknown Source)
    at javax.xml.parsers.SAXParser.parse(Unknown Source)
    at javax.xml.parsers.SAXParser.parse(Unknown Source)
    at org.apache.catalina.util.xml.XmlMapper.readXml(Xml Mapper.java:228)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:725)
    at org.apache.catalina.startup.Catalina.execute(Catal ina.java:681)
    at org.apache.catalina.startup.Catalina.process(Catal ina.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:243)
is there something missing in the server config?
deployment description is as following
<?xml version="1.0" encoding="UTF-8"?>
<web-app id="WEBsOne" version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
    <display-name>WEBsOne</display-name>
    <servlet>
    <servlet-name>SnoopServlet</servlet-name>
    <servlet-class>com.networkedObjects.root.SnoopServlet</servlet-class>
    </servlet>
    <servlet-mapping>
    <servlet-name>Snoop Servlet</servlet-name>
    <url-pattern>/snoop/*</url-pattern>
    </servlet-mapping>
    <welcome-file-list>
        <welcome-file>index.html</welcome-file>
        <welcome-file>index.htm</welcome-file>
        <welcome-file>index.jsp</welcome-file>
        <welcome-file>default.html</welcome-file>
        <welcome-file>default.htm</welcome-file>
        <welcome-file>default.jsp</welcome-file>
    </welcome-file-list>
</web-app>

thanks in advance.
mayuresh.






Similar Threads
Thread Thread Starter Forum Replies Last Post
DTC fails to work with SQL Server after changing t titojermaine SQL Server 2005 0 July 24th, 2007 07:24 AM
Login Control fails on server PeterX ASP.NET 2.0 Basics 0 July 25th, 2006 10:53 AM
SQL Server error 4060 - Login fails Sksdb SQL Server 2000 0 January 18th, 2005 07:02 AM
printing to server fails, and I dont know why weekly_s Crystal Reports 0 September 29th, 2003 03:53 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.