Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Java > Java Open Source > Apache Tomcat
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Apache Tomcat General discussion of the Apache Tomcat servlet container. For discussions specific to the Professional Apache Tomcat book, please see the book discussion forum for that book.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Apache Tomcat section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old September 14th, 2007, 09:11 AM
Registered User
 
Join Date: Sep 2007
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default can't see jars in shared/lib?

hello. working with tomcat 5.5. i have a few webapps which share a library for db connectivity, etc. so i deploy the three webapps and put the db library in shared/lib. but the webapps can't see it. when they reach that point in processing, they just stop. i've also tried common/lib - same result.

any help is greatly appreciated.
thanks
chris
Reply With Quote
  #2 (permalink)  
Old September 14th, 2007, 02:07 PM
Authorized User
 
Join Date: Apr 2005
Location: , , India.
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds weird, what is the error message that you see?

-eNJay
Reply With Quote
  #3 (permalink)  
Old September 14th, 2007, 02:48 PM
Registered User
 
Join Date: Sep 2007
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello. no error message. but nobody believes me when i say that, so i'll give you a simpler case. i deploy the webapp with everything except the hibernate config file (must be in the classpath). So i drop the hibernate file in shared/classes - and when i run the app i get a message saying that it can't find the hibernate config file. if i move that file to the webapp's WEB-INF/classes directly, it works perfectly.

thanks for your time
chris
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
packaging 3rdparty executable jars for my swings Adabalakumar Java GUI 1 July 24th, 2008 06:41 AM
CustomEvents Lib Project tectrix BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 10 June 16th, 2007 12:59 PM
where do the xerces jars go tovachanah Apache Tomcat 0 March 27th, 2007 06:40 PM
e-Book and Lib.info Help koneruvijay General .NET 1 August 16th, 2004 02:42 PM



All times are GMT -4. The time now is 05:48 PM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.