Wrox Programmer Forums
Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP.NET 1.0 and 1.1 > ASP.NET 1.0 and 1.1 Basics
| Search | Today's Posts | Mark Forums Read
ASP.NET 1.0 and 1.1 Basics ASP.NET discussion for users new to coding in ASP.NET 1.0 or 1.1. NOT for the older "classic" ASP 3 or the newer ASP.NET 2.0.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 1.0 and 1.1 Basics section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old August 17th, 2004, 02:32 PM
Registered User
 
Join Date: Aug 2004
Location: Dacula, Georgia, USA.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default can't create web form from visual studio

  I get the following message when I try to create a web form from visual studio.

    Visual Studio.NET has detected that the specified web server is not running ASP.NET version 1.1. You will be unable to run ASP.NET web applications or services.

I downloaded and installed ASP.NET version 1.1. Why am I getting this message?

Thanks,
Keith Stallings

Keith Stallings
  #2 (permalink)  
Old August 17th, 2004, 03:02 PM
Friend of Wrox
 
Join Date: Jun 2003
Location: Harrisburg, PA, USA.
Posts: 1,998
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Hey,

Does the aspnet_client folder exist in your wwwroot (or equivalent) folder?

Brian
  #3 (permalink)  
Old August 17th, 2004, 03:38 PM
Registered User
 
Join Date: Aug 2004
Location: Dacula, Georgia, USA.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did a search and the "aspnet_client" folder doesn't exist anywhere on my computer. I have visual studio.net professional. Maybe I need a higher version to use web applications or services??
thanks,
Keith Stallings

Keith Stallings
  #4 (permalink)  
Old August 17th, 2004, 04:58 PM
Registered User
 
Join Date: Aug 2004
Location: Dacula, Georgia, USA.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found that since I installed iis after visual studio the registry was messed up. The .net framework has a program to run which fixes this.
      Run the following program under dos

      aspnet_regiis.exe -i


Keith Stallings
  #5 (permalink)  
Old August 18th, 2004, 07:18 AM
Friend of Wrox
 
Join Date: Jun 2003
Location: Harrisburg, PA, USA.
Posts: 1,998
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Hey,

Yeah, it's not the version. I've found reinstalling the .NET framework helps. My problem in the past was I switched the wwwroot folder to another path, and because the aspnet_client folder wasn't there, I had to reinstall the .NET framework. Copying/pasting the folder might have worked also.

Brian


Similar Threads
Thread Thread Starter Forum Replies Last Post
Visual Studio VS. Visual Web Developer expr Astrocloud BOOK: Beginning ASP.NET 2.0 BOOK VB ISBN: 978-0-7645-8850-1; C# ISBN: 978-0-470-04258-8 2 November 23rd, 2008 03:10 PM
how to create ASP page in visual studio.net madhusrp Other Programming Languages 3 March 2nd, 2006 03:07 AM
Threading in Visual Studio in a Web Page jainnid General .NET 2 April 28th, 2005 02:57 AM
Create C# Web App Visual Studio on remote IIS 6 lange Classic ASP Professional 0 July 31st, 2004 09:34 AM
Beginning C# Web Applications with Visual Studio rodmcleay All Other Wrox Books 4 October 9th, 2003 10:25 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.