Wrox Programmer Forums
|
ASP.NET 1.0 and 1.1 Basics ASP.NET discussion for users new to coding in ASP.NET 1.0 or 1.1. NOT for the older "classic" ASP 3 or the newer ASP.NET 2.0.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 1.0 and 1.1 Basics section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old March 31st, 2006, 12:30 PM
RGB RGB is offline
Authorized User
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Required Field Validator

My problem is that when I use a REQUIRED FIELD VALIDATOR on a page it works fine on my machine (localhost), but when I push it to our production Web Server the Validator does not work. I have made sure that the JavaScript file is on our production server, and it is, but the IIS on our production server is set up differently than my IIS on my machine (localhost). A Little Help would be great!

What Do You Mean It Does Not Work
__________________
What Do You Mean It Does Not Work
 
Old March 31st, 2006, 02:23 PM
Wrox Author
 
Join Date: Oct 2005
Posts: 4,104
Thanks: 1
Thanked 64 Times in 64 Posts
Send a message via AIM to dparsons
Default

First off, love your user name. Second off, how do you have the RFV setup? Do you have it setup to display an error message as a label, in a Validation Summary, or in a message box? Are you getting an error of any sort?

"The one language all programmers understand is profanity."
 
Old March 31st, 2006, 03:22 PM
RGB RGB is offline
Authorized User
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have it set to show an * then next to the submit button I have a Validation Summary. I am not getting any error. I assume that it is not seeing the jscript on our Production Server, but the file aspnet_client\system_web\1_1_4322\WebUIValidations .js is on both my local and production server. Like I say the file lives in a different location on the IIS tree on our production server, but other developers have no problems with this.

What Do You Mean It Does Not Work
 
Old March 31st, 2006, 03:31 PM
Wrox Author
 
Join Date: Oct 2005
Posts: 4,104
Thanks: 1
Thanked 64 Times in 64 Posts
Send a message via AIM to dparsons
Default

hmm that doesn't make sense, b/c is the script couldn't find the JS you would get an error saying WebUIValidations.js cannot be found. Think more on this I must.

"The one language all programmers understand is profanity."





Similar Threads
Thread Thread Starter Forum Replies Last Post
required field validator rocksbhavesh ASP.NET 1.0 and 1.1 Basics 2 June 30th, 2007 03:20 AM
Custmization in Required Field validator shivendra012 ASP.NET 1.0 and 1.1 Professional 1 April 19th, 2007 05:14 AM
What's wrong with required field validator? bhavna General .NET 1 February 8th, 2007 10:25 AM
Required Field Validator Issue vivek_inos ASP.NET 1.0 and 1.1 Professional 2 September 18th, 2006 07:57 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.