Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP.NET 2.0 > ASP.NET 2.0 Professional
Password Reminder
Register
| FAQ | Members List | Search | Today's Posts | Mark Forums Read
ASP.NET 2.0 Professional If you are an experienced ASP.NET programmer, this is the forum for your 2.0 questions. Please also see the Visual Web Developer 2005 forum.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 2.0 Professional section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old June 5th, 2006, 04:18 AM
Registered User
 
Join Date: Jun 2006
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default calling .exe from asp.net c#

Hi all,
 I'm using visual web developer to develop my asp.net applications. The requirement is to call an executable file from one of the aspx pages on the click event of a button.
 The good news is that I've achieved it using the process class function and it runs fine when I start debugging from the Visual web developer environment.
 Here comes the bad news. When I deploy this page on localhost and click on the button, the desired process starts < I can say this because it's there in the task manager's process tab > but the console application <window> is not displayed. < Also the application tab of the task manager doesn't have this exe file shown >

My observation:
 When I run the page with Visual Web Developer environment, the invoked application runs with my user-name against it. But when I run the page after deploying at the local-host, it runs with ASPNET user-name against it.

My tries:
I tried to load window's user profile and tried to run it... It loaded the process with my user-name alright, but it abruptly ended with a 0x00000142 error < I aint sure about the number of 0s it has :) > I looked up in Google and found that this error has to do something with user.dll

Please Help :( :
 Now you know what kind of mess I'm in, please try and help me get out of this.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Call .exe from asp.net with c# vishwanath.yr ASP.NET 2.0 Basics 0 June 5th, 2006 04:10 AM
Calling a .exe or .vbs file from ASP komalac Classic ASP Basics 1 September 16th, 2004 03:04 AM
Calling an ActiveX.EXE in C++ xgbnow Visual C++ 4 March 31st, 2004 08:12 AM
How can I call a vb.net Exe from an asp.net page? jorevil Classic ASP Basics 0 October 1st, 2003 11:34 AM
calling exe from asp.net delcyan VS.NET 2002/2003 0 September 2nd, 2003 03:19 PM



All times are GMT -4. The time now is 07:53 AM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.