Wrox Programmer Forums
Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP.NET 2.0 > ASP.NET 2.0 Professional
|
ASP.NET 2.0 Professional If you are an experienced ASP.NET programmer, this is the forum for your 2.0 questions. Please also see the Visual Web Developer 2005 forum.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 2.0 Professional section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old June 22nd, 2007, 03:59 PM
Friend of Wrox
 
Join Date: Jul 2004
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Default IMG Displays but text field is not displayed.

 IMage is displayed but the data field is not displayed in item template not sure. Please help
<asp:GridView ID="GridView1" runat="server" AutoGenerateColumns=False DataKeyNames="ppID" CellPadding="4" ForeColor="#333333" GridLines=Both OnSelectedIndexChanged="GridView1_SelectedIndexCha nged">
         <Columns>


        <asp:HyperLinkField DataTextField="ppID" DataNavigateUrlFields="ppID" DataNavigateUrlFormatString="ppUpdateAdmin.aspx?pp id={0}"
HeaderText="ppID" />
   <asp:TemplateField HeaderText="Company">
            <ItemTemplate>
                <a href="">
<img border="0" src="C:/DirPurchasingPeople/Images/sList.jpg" width="20" height="15" alt="">

      <asp:HyperLinkField DataTextField=ppID DataNavigateUrlFields="ppID" DataNavigateUrlFormatString="srchDtlPP.aspx?ppid={ 0}" />


            </ItemTemplate>
        </asp:TemplateField>



 
Old June 25th, 2007, 04:27 AM
Friend of Wrox
 
Join Date: May 2006
Posts: 107
Thanks: 1
Thanked 8 Times in 7 Posts
Default

Try this. (Check the syntax first I may have pasted from my code incorrectly)



<asp:HyperLink ID="HyperLink1" runat="server" NavigateUrl='<%# Eval("ppID", "ppUpdateAdmin.aspx?ppid={0}") %>'
ImageUrl='C:/DirPurchasingPeople/Images/sList.jpg") %>'>
</asp:HyperLink>

regards

Tim


 
Old June 25th, 2007, 06:04 AM
planoie's Avatar
Friend of Wrox
 
Join Date: Aug 2003
Posts: 5,407
Thanks: 0
Thanked 16 Times in 16 Posts
Default

You can't use local file names for image sources. If I browse to your site, where do I get the image? I don't have a c:\DirPurchasingPeople directory.

-Peter





Similar Threads
Thread Thread Starter Forum Replies Last Post
#Error displayed in text box on report RayL Access VBA 3 March 16th, 2007 07:12 AM
Text Box .text Property Displays conflicting Valus JPOhlman Visual Basic 2005 Basics 3 August 23rd, 2006 02:39 PM
text displayed incorrectly kmfdm515 ASP.NET 1.0 and 1.1 Basics 0 December 13th, 2004 01:22 PM
Align IMG with text Snib HTML Code Clinic 12 April 8th, 2004 10:16 AM
How to open Word imbeded in SQL Srv img field? slava123 ADO.NET 0 November 12th, 2003 05:09 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.