Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0
This is the forum to discuss the Wrox book ASP.NET 2.0 Website Programming: Problem - Design - Solution by Marco Bellinaso; ISBN: 9780764584640
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old August 30th, 2006, 03:45 PM
Friend of Wrox
 
Join Date: Aug 2006
Location: , , .
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to kherrerab Send a message via Yahoo to kherrerab
Default no rss information on default page

hi all. when i tested the site on local machine it worked fine. After uploaded it does not show all the rss info about the articles and forums.

just a blank page.

heres a pic
http://img239.imageshack.us/img239/7374/rssbu1.jpg

http://img156.imageshack.us/img156/9419/rssuy6.jpg
  #2 (permalink)  
Old August 31st, 2006, 03:37 PM
Friend of Wrox
 
Join Date: Aug 2006
Location: , , .
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to kherrerab Send a message via Yahoo to kherrerab
Default

well i think i have found the problem. The record on the table aspnet_applications has to be the same as the IIS virtual directory. It fully runs on IIS localy now but not on the hosting server.

I don´t know what is the directory, all i know is that of course the files are on clubvwnica.com\wwwroot but this path does not work.

Still no rssreader on default page.

Please help me!

  #3 (permalink)  
Old August 31st, 2006, 06:21 PM
Authorized User
 
Join Date: May 2006
Location: , , .
Posts: 99
Thanks: 0
Thanked 1 Time in 1 Post
Default

The problem may be that your host doesn't have SQLExpress, which is designed to be used for development. If your host has SQL Server 2005 you'll have to get the specifics you need to connect, then read chapter 12 about deploying the site.

  #4 (permalink)  
Old September 1st, 2006, 08:25 AM
Friend of Wrox
 
Join Date: Aug 2006
Location: , , .
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to kherrerab Send a message via Yahoo to kherrerab
Default

thanks for the answer but that´s not the solution.

I fount that the solution is in the aspnet_applications table.
I changed the applicationid of mine and changed the application id to "/"
I found this when trying to run the app in local IIS.

This is the solution for this.

Now i must find why the fckedito does not work with firefox.

You can see the site running at www.clubvwnica.com

  #5 (permalink)  
Old September 18th, 2006, 04:41 PM
Authorized User
 
Join Date: Jun 2006
Location: Shawnee, OK, USA.
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having the same issue but have been unable to correct it. Can you be more specific on your fix?

  #6 (permalink)  
Old September 18th, 2006, 06:29 PM
Friend of Wrox
 
Join Date: Aug 2006
Location: , , .
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to kherrerab Send a message via Yahoo to kherrerab
Default

is your web site online or are you testing it in iis?

  #7 (permalink)  
Old September 19th, 2006, 02:22 PM
Authorized User
 
Join Date: Jun 2006
Location: Shawnee, OK, USA.
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Online is where the problem is but it's my own webserver. If I hit the site localhost from the server itself all is fine.

  #8 (permalink)  
Old September 19th, 2006, 02:27 PM
Friend of Wrox
 
Join Date: Aug 2006
Location: , , .
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to kherrerab Send a message via Yahoo to kherrerab
Default

find the table aspnet_applications, then applicationid. it normally says //thebeerhouse (i think it did), change the name to your IIS virtual directory name.

Example on mine IIS directory test i uses //wwwroot since it was the name of the virtual directory and the name of the hard disk directory.


  #9 (permalink)  
Old September 19th, 2006, 02:28 PM
Friend of Wrox
 
Join Date: Aug 2006
Location: , , .
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to kherrerab Send a message via Yahoo to kherrerab
Default

can i see your site online? url?

  #10 (permalink)  
Old September 20th, 2006, 08:51 AM
Authorized User
 
Join Date: Jun 2006
Location: Shawnee, OK, USA.
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can see my site online but without the rss. I have two entries in the aspnet_applications table. Originally one was "/" and the other "/TBH_Web". My webserver directory is "D:\WebDev\casa1" but after changing the "/TBH_Web" entry to "/WebDev/casa1" or several other options still no change. I figured I'd hit on it eventually but it doesn't appear to be as easy as that. I'll keep trying. Thanks for any suggestions.





Similar Threads
Thread Thread Starter Forum Replies Last Post
Re-printing information on a new page. Tre XSLT 3 May 21st, 2007 04:27 PM
Extend CMS: How to create rss in Default page? thuyvncr BOOK: ASP.NET 2.0 Instant Results ISBN: 978-0-471-74951-6 8 April 26th, 2007 06:16 AM
redirect to page other than default page sarah lee ASP.NET 1.0 and 1.1 Basics 3 December 15th, 2006 05:45 PM
Blank Default Page ghrebek BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 8 December 5th, 2006 08:09 PM
Transformation htm of page in rss Serjio RSS and Atom 0 August 6th, 2006 02:14 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.