Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0
This is the forum to discuss the Wrox book ASP.NET 2.0 Website Programming: Problem - Design - Solution by Marco Bellinaso; ISBN: 9780764584640
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old February 9th, 2007, 03:55 PM
Registered User
 
Join Date: Feb 2007
Location: , , USA.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default New Member Install TBH problem

Here is what I have done. I unzipped the vb version to a local directory - d drive. I created a virtual directory in IIS for the program. When I open the project, and run it (not sure what to set as the start position), I receive error:

It is an error to use a section registered as AllowDefinition='MachineToApplication' beyond application level. this error can be caused by a virtual directory not being configured as an Application in IIs.

I am a windows not internet programmer, but have already created a working asp.net 2.0 app with sql express so I have all the programs necessary to run this, I think. I am using xp and IIS 5.1

I had decided to set this up before starting the book. Perhaps there is information on setting it up I need to read first somewhere.
Thanks
smhaig

  #2 (permalink)  
Old February 9th, 2007, 04:56 PM
Friend of Wrox
 
Join Date: Mar 2006
Location: , , Portugal.
Posts: 310
Thanks: 0
Thanked 0 Times in 0 Posts
Default

you don't have visual studio?

If you deploy the project to the root folder of an IIS site, you have to identify the root folder with "/".
if you deploy the site on a sub virtual folder, you use "~/"

If you have visual studio, delete you iis virtual directory, open the solution run the project from there.

(I don't know if this helps... but you can try)

  #3 (permalink)  
Old February 10th, 2007, 01:10 PM
Registered User
 
Join Date: Feb 2007
Location: , , USA.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I do have Visual Studio. I deleted the virtual directory and ran the program in VS (I am using the VB version by the way)and I did not get that error. There were a bunch of errors refering to the
MB.TheBeerHouse.UI.Controls but the 'Inherits BaseWebPart' line had been commented out. Now it works.

Thanks so much

  #4 (permalink)  
Old February 10th, 2007, 01:33 PM
Friend of Wrox
 
Join Date: Mar 2006
Location: , , Portugal.
Posts: 310
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes! MythicalMe did a precious work but i was forgotten to uncomment this line after upload the source code.

I already advised him to modify this because this can discourage some people when try to debug and see more than 40 errors...

Good luck!


Similar Threads
Thread Thread Starter Forum Replies Last Post
TBH install problems jjmonty BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 5 September 26th, 2006 05:23 PM
TBH Install Problem bigzip BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 1 September 6th, 2006 06:33 PM
A problem about the use of the private member yuanlairuci BOOK: Professional C#, 2nd and 3rd Editions 1 April 7th, 2005 02:24 AM
A problem about the use of the private member yuanlairuci C# 2 March 23rd, 2005 09:42 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.