Wrox Programmer Forums
|
BOOK: ASP.NET Website Programming Problem-Design-Solution
This is the forum to discuss the Wrox book ASP.NET Website Programming: Problem - Design - Solution, Visual Basic .NET Edition by Marco Bellinaso, Kevin Hoffman; ISBN: 9780764543869
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: ASP.NET Website Programming Problem-Design-Solution section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old August 25th, 2004, 04:35 AM
Authorized User
 
Join Date: Aug 2004
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default ThePhile 113 Build Errors

Hi,

Still having trouble getting ThePhileVB to run (see my previous posting) ThePhile References cannot be found.

I changed the server name in Web.config.
But trying to build ThePhileVB I was confronted with 113 Build Errors.
(mostly not defined or cannot be found errors)

For example: (First 3)
____________________________________________
AppException is not a member of WebModules.

Namespace or type 'Business' for the Imports' Wrox.WebModules.Accounts.Business' cannot be found.

Type 'SitePrincipal' is not defined.
________________________________________




At first I made Wrox the virtual directory because of the Wrox namespace, but I was unable to view the files.

Then I made ThePhileVB the virtual directory I can view the files through Visual Studio but not run them. It seems ridiculous but it appears to have a problem with Wrox as a reference throughout.

My Visual Studio is 2003 is that why it won't run properly? Because it needed to update ThePhile files before it was made available for view.

What would have been altered in the VS update?

What must I do to make it run?

Or am I missing something?

It seems quite drastic but should I take out the Wrox part of the reference throughout the application?


Please advise as I am trying to rebuild the code from scratch using my own namespaces. I would like to avoid the same build errors which I am sure I would encounter if I used the code as it is, I would like to see it running so that I can compare.

Please help.



Thanks

Lynn

__________________
Lynn
 
Old September 26th, 2005, 08:27 PM
Registered User
 
Join Date: Sep 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

has anyone solved this problem? i am getting the same exactly "113 build errors"
 
Old September 26th, 2005, 10:25 PM
Authorized User
 
Join Date: Jul 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please set up a startup project, then recompile it again! If you don't know how to set up a startup project, check it on the google.

 
Old September 27th, 2005, 01:20 PM
Registered User
 
Join Date: Sep 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem and I just added the references again pointing to the files in the wrox\thephilevb\bin directory using the wrox.webmodules name instead of the short names they had. Of course I deleted the old references afterward.

 
Old September 27th, 2005, 01:39 PM
Registered User
 
Join Date: Sep 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks RickDagger for your reply

After 4 days of trying to get this project to run, finally i was able to. I DID NOT delete any .dll or pdb and i am using VS 2003.

just selected the project name and i want open after i had setup my IIS and permissions :D






Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Build Errors Aaron Edwards ASP.NET 2.0 Basics 1 November 2nd, 2007 03:04 AM
Build Errors..Not Sure What to Do?? jazzcatone ASP.NET 2.0 Basics 2 March 8th, 2007 02:24 PM
VC++ Build Errors, Help!!!!!!!!! gothicpurple Visual C++ 0 August 29th, 2006 06:35 PM
build errors in vc++ angel188 Visual C++ 0 June 6th, 2006 06:41 AM
Please Help! Build errors motsam BOOK: ASP.NET Website Programming Problem-Design-Solution 2 February 29th, 2004 10:37 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.