Wrox Programmer Forums

Need to download code?

View our list of code downloads.

| FAQ | Members List | Search | Today's Posts | Mark Forums Read
BOOK: ASP.NET Website Programming Problem-Design-Solution
This is the forum to discuss the Wrox book ASP.NET Website Programming: Problem - Design - Solution, Visual Basic .NET Edition by Marco Bellinaso, Kevin Hoffman; ISBN: 9780764543869
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: ASP.NET Website Programming Problem-Design-Solution section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old July 18th, 2003, 06:38 AM
Registered User
 
Join Date: Jul 2003
Location: Hephzibah, GA, USA.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default calling __doPostBack want fire in I.E. 5.0

This bug has my application crippled in I.E. 5.0.
Simular code is in the FileUpload WebModule. I don't think that will work in I.E. 5.0 either.

I'm calling the __doPostBack Fuction from my custom javascript function Submit(pict)
It never reaches it in i.e. 5.0
I'm using 1.1 framework. It works fine in i.e. 5.5 and 6.0 but not i.e. 5.0

You can see an example of the problem at http://www.ineedatour.com/smalltour.aspx?ID=2
using I.E. 5.0 The pictures will not change.

I'm pretty sure the problem that my custom SubmitPict(pict) function cannot call __doPostBack('ChangePict',''). It works in the other browsers fine.

<SCRIPT language="javascript">
function SubmitPict(pict)
{
if((pict) && (pict != "")){
document.forms['images'].elements['PictNum'].value = pict;
__doPostBack('ChangePict','');// THIS CODE WILL NOT CALL THE __doPostBack Function
}
}
</SCRIPT>

//This is the generated __doPostBackFunct
<script language="javascript">
<!--
function __doPostBack(eventTarget, eventArgument) {
var theform;
if (window.navigator.appName.toLowerCase().indexOf("n etscape") > -1) {
theform = document.forms["images"];
}
else {
theform = document.images;
}
theform.__EVENTTARGET.value = eventTarget.split("$").join(":");
theform.__EVENTARGUMENT.value = eventArgument;
theform.submit();
}
// -->
</script>

  #2 (permalink)  
Old July 18th, 2003, 09:32 PM
DKS DKS is offline
Registered User
 
Join Date: Jul 2003
Location: Glendale, WI, USA.
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check out the help topic for Page.ClientTarget. It says that by default it gets set to IE5 (but this setting assumes IE5.5 and above). You may want to try clienttarget="uplevel" in the @page directive of the pages where you need this and see if it works any better. Good Luck. Let us know if it works.
  #3 (permalink)  
Old July 18th, 2003, 10:20 PM
Registered User
 
Join Date: Jul 2003
Location: Hephzibah, GA, USA.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you very much for responding and trying to help me.
That didn't seem to help anything.
<%@ Page CodeBehind="st.aspx.cs" Language="c#" Debug="true" AutoEventWireup="false" Inherits="KelleyWeb.Web.smalltour" clientTarget="uplevel"%>

Any more ideas?

Tim

  #4 (permalink)  
Old July 24th, 2003, 04:51 PM
Registered User
 
Join Date: Jul 2003
Location: Hephzibah, GA, USA.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay I have my answer.
Microsoft says they only support I.E. 5.01 Windows 2000 sp3.

The browser that I was having problems with was version 5.0.
I changed the name of the Url, many of you could not reach the page.
It was changed to www.iNeedaTour.com/st.aspx?id=2
thanks,
Tim


 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CustomValidator won't fire method cridley General .NET 4 August 4th, 2009 05:37 AM
dropdownlist1_selectedindexchanged doesn't fire rsearing ASP.NET 1.0 and 1.1 Basics 2 February 14th, 2007 01:44 PM
SelectedIndexChanged Event doesn't fire ddudley3 ASP.NET 2.0 Professional 7 February 6th, 2006 10:47 AM
Help My house on Fire Matthew Access VBA 9 November 30th, 2005 03:21 PM



All times are GMT -4. The time now is 03:17 AM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.