Wrox Programmer Forums

Need to download code?

View our list of code downloads.

| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: ASP.NET Website Programming Problem-Design-Solution
This is the forum to discuss the Wrox book ASP.NET Website Programming: Problem - Design - Solution, Visual Basic .NET Edition by Marco Bellinaso, Kevin Hoffman; ISBN: 9780764543869
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: ASP.NET Website Programming Problem-Design-Solution section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #11 (permalink)  
Old September 19th, 2003, 03:22 PM
Registered User
 
Join Date: Sep 2003
Location: , , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm getting the same

Access to the path "C:\wrox\ThePhileVB\Config\Polls.Config" is denied.

error message. I'm also using XP Pro, VS 2002 Enterprise, and Framework 1.1. The workaround doesn't seem to work for me. I'm modifying WebModules/Polls/Polls.Configuration/obj/ModuleConfig.vb file. I change the fs constructor, but the file is greyed out. I rebuild, and the error is still there. I try to Include in Project, but then I get an ambiguous namespace problem.

Am I modifying the correct file?

This is extremely annoying.....

  #12 (permalink)  
Old September 19th, 2003, 05:35 PM
Authorized User
 
Join Date: Jul 2003
Location: , , .
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You may want to make sure that your websites Directory Security settings in IIS has anonymous access unchecked. Compare your site by looking at the thephile's IIS settings, by bringing up Properties when your in Internet Information Services, goto Directory Security, click Edit under Annonymous access and authentication control, then check to see if the Annonymous access check box is checked or not. For your site to work properly you may need to have the check box unchecked.

look at some of my previous posts here if you get a database error after you fix this such as Login failed for user 'sa'.
http://p2p.wrox.com/pop_profile.asp?...isplay&id=3425

  #13 (permalink)  
Old September 20th, 2003, 11:35 AM
Registered User
 
Join Date: Sep 2003
Location: , , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not trying to develop this in another site - I'm just trying to get the sample site running!

  #14 (permalink)  
Old December 16th, 2003, 01:03 AM
Authorized User
 
Join Date: Jun 2003
Location: , , Congo, Democratic Republic of.
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would like to know, if there is anyway to wrtie to a .config file when aspnet account doesn't have does rights. Also, Impersonate is not an option for me.

Answers welcomed, because I haven't found a single answer to this on ze web.

Cheers,

Kim Gjerstad
  #15 (permalink)  
Old December 22nd, 2003, 10:06 PM
Authorized User
 
Join Date: Nov 2003
Location: LA, CA, USA.
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

As far as I remember, I fixed this error from open Windows explorer > browse to the config file>right click>Properties>security tab>

Then see if the ASPNET user is there. If not add it. Then allow the control for this new user.

Hope this might help.

Thanks
Musa

  #16 (permalink)  
Old April 12th, 2005, 03:24 PM
Registered User
 
Join Date: Sep 2004
Location: , , .
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

make sure you do not have this in config:
<identity impersonate="true" />
resolved my problem

  #17 (permalink)  
Old May 4th, 2005, 01:12 PM
Registered User
 
Join Date: May 2005
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great guys!
The combination of deny'ing anonymous access and setting <identity impersonate="true" /> in web.config did it for me!

Thanks guys

  #18 (permalink)  
Old August 27th, 2005, 04:29 PM
Registered User
 
Join Date: Aug 2005
Location: , , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
quote:Originally posted by tworkman
 Excellent. Your fix did it Clay. For anybody else that comes along with this problem, VB syntax is the same as C# syntax...

Thanks for posting,
Tim

Actually, the VB code is:
Dim fs As New FileStream(fileName, FileMode.Open, FileAccess.Read)

This along with the Anomynous user checkbox unchecked did it for me. Note: you have to change the above code in two places in that ModuleConfig file.

  #19 (permalink)  
Old October 25th, 2006, 12:57 PM
Authorized User
 
Join Date: Feb 2006
Location: , , .
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi All.
I have machine with Framework .NET 1.1, Visual Studio .NET 2003 and SQL Server 2000.
According Readme.html file I did configuration of my machine. When I done and click link http://localhost/thephileVB I got an error.
Quote:
quote:
The error occurred in:
http://localhost/thephileVB/Default.aspx

Error Message:
Access to the path 'C:\wrox\ThePhileVB\Config\Polls.Config' is denied.
At the buttom of readme.html file I found advice for that error:
Quote:
quote:
You need to modify the FileStream constructors in the ModuleConfig.vb or ModuleConfig.cs files as described below.

Users with VB.NET version of Code

Dim fs As New FileStream(fileName, FileMode.Open, FileAccess.Read)
After changes and rebuid solution was done I got other message:
Quote:
quote:
The error occurred in:
http://localhost/thephileVB/Default.aspx

Error Message:
An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
Thanks for any help.

  #20 (permalink)  
Old June 22nd, 2007, 08:26 AM
Registered User
 
Join Date: Jun 2007
Location: mumbai, maharashtra, India.
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to rana_pawar
Default

Hello I am Having WebServer
I am hosting my files with FTP
I am creating few folder Dynamically
But It Gives Me Same Error as Above
Access Denied
PLz help Me e Out
I am Having Access to the Web Server But Do Not Have any User Like ASPNET there on web Server

 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parse error: syntax error, unexpected T_ELSE in /h vipin k varghese BOOK: XSLT Programmer's Reference, 2nd Edition 4 September 29th, 2011 01:19 AM
error occurred... craft Dreamweaver (all versions) 1 November 1st, 2008 04:31 AM
Ch 4: Parse error: syntax error, unexpected T_SL hanizar77 BOOK: Beginning PHP5, Apache, and MySQL Web Development ISBN: 978-0-7645-7966-0 0 June 23rd, 2008 09:17 PM
Parse error: syntax error, unexpected T_STRING ginost7 Beginning PHP 1 November 9th, 2007 02:51 AM
error:Exception occurred hastikeyvan Classic ASP Professional 1 September 13th, 2006 04:40 AM



All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.