Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Register | FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: Beginning ASP.NET 4.5 : in C# and VB
This is the forum to discuss the Wrox book Beginning ASP.NET 4.5: in C# and VB by Imar Spaanjaars; ISBN: 978-1-118-31180-6
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Beginning ASP.NET 4.5 : in C# and VB section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old July 22nd, 2013, 11:15 PM
Friend of Wrox
Points: 1,905, Level: 17
Points: 1,905, Level: 17 Points: 1,905, Level: 17 Points: 1,905, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2011
Posts: 411
Thanks: 13
Thanked 7 Times in 7 Posts
Default Email deployment issue

I don't know if you know this or not, but I used the application from the book as a blueprint for a E-commerce website for demonstration purposes only for upcoming job interviews. Everything is working just fine except the contact form part. That is totally just hosing out and is not working. That part works just fine from my side of the equation when I run it locally on my home PC, but when I deploy the application to the web hosting server, that part just totally chokes up and does not work. None of the email notifications are working. I was just wondering what can be done to fix this?
I noticed the material on pages 732-38 about the appsettings stuff, but I didn't not make those changes or modifications to my application on my local home PC when I uploaded and the application to the actual production application server. I thought that if the email stuff could run properly on my side at home on my home PC that it should work also just as fine and well when you uploaded the application to the actual remote production server. Unfortunately, such is not the case. It seems to be having problems.

Thanks once again.
Reply With Quote
  #2 (permalink)  
Old July 25th, 2013, 06:45 PM
Authorized User
Points: 175, Level: 3
Points: 175, Level: 3 Points: 175, Level: 3 Points: 175, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2013
Location: St.Petersburg, Russia
Posts: 36
Thanks: 1
Thanked 4 Times in 4 Posts
Default <mailSettings>

What's in your web.config in <system.net><mailSettings>?

You may want to make sure that the following settings are correct:

<smtp deliveryMethod="network" from="...">
<network
clientDomain="..."
host="..."
userName="..."
enableSsl="true/false"
Reply With Quote
  #3 (permalink)  
Old July 30th, 2013, 01:51 PM
Imar's Avatar
Wrox Author
Points: 72,022, Level: 100
Points: 72,022, Level: 100 Points: 72,022, Level: 100 Points: 72,022, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,076
Thanks: 80
Thanked 1,587 Times in 1,563 Posts
Default

The section "Configuring Your Website for Sending E-mail" on page 334 has all the details. You'll need to talk to your host for the specific configuration information such as the mail server and account data.

Cheers,

Imar
__________________
Imar Spaanjaars
http://Imar.Spaanjaars.Com
Follow me on Twitter

Author of Beginning ASP.NET 4.5 : in C# and VB, Beginning ASP.NET Web Pages with WebMatrix
and Beginning ASP.NET 4 : in C# and VB.
Did this post help you? Click the button below this post to show your appreciation!
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deployment Issue Ascerbus BOOK: Beginning ASP.NET 3.5 : in C# and VB BOOK ISBN: 978-0-470-18759-3 4 February 13th, 2009 06:52 AM
Deployment Issue REPicurus Access 1 May 28th, 2008 02:21 AM
Deployment Issue sbv002 BOOK: ASP.NET 2.0 Website Programming Problem Design Solution ISBN: 978-0-7645-8464-0 0 November 20th, 2007 03:56 PM
Deployment issue - TypeInitializationException eelisMX Pro VB.NET 2002/2003 0 March 31st, 2005 04:54 AM
deployment issue p_gauri7 Crystal Reports 0 January 19th, 2005 11:32 PM



All times are GMT -4. The time now is 09:01 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.