Wrox Programmer Forums
Go Back   Wrox Programmer Forums > Open Source > BOOK: Beginning Ruby on Rails
| Search | Today's Posts | Mark Forums Read
BOOK: Beginning Ruby on Rails
This is the forum to discuss the Wrox book Beginning Ruby on Rails by Steve Holzner Ph.D.; ISBN: 9780470069158
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Beginning Ruby on Rails section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old January 20th, 2007, 09:14 PM
Registered User
 
Join Date: Jan 2007
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Chapter 1, First App, No, it's not working

Hi there,
Just opened the book.
Followed the steps, ran webrick and browsed to the /app/greeting URL and webrick threw:

#<ArgumentError: Anonymous modules have no name to be referenced by>
["/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:405:in `to_constant_name'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:215:in `qualified_name_for'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:477:in `const_missing'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:117:in `reset_after_dispatch'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:51:in `dispatch'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/webrick_server.rb:113:in `handle_dispatch'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/webrick_server.rb:79:in `service'", "/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'", "/usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'", "/usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'", "/usr/lib/ruby/1.8/webrick/server.rb:162:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'", "/usr/lib/ruby/1.8/webrick/server.rb:95:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:92:in `each'", "/usr/lib/ruby/1.8/webrick/server.rb:92:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/webrick_server.rb:63:in `dispatch'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/commands/servers/webrick.rb:59", "/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'", "/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in `require'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in `new_constants_in'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in `require'", "/usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/commands/server.rb:39", "/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'", "/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in `require'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in `new_constants_in'", "/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in `require'", "script/server:3"]
[2007-01-21 10:56:26] ERROR `/app/greeting' not found.
203.51.183.13 - - [21/Jan/2007:10:56:25 EST] "GET /app/greeting HTTP/1.1" 404 292

I'm obviously a complete noooob so I'm not sure where to start (obviously I've done some googling...).

Thanks muchly for your help!
r

  #2 (permalink)  
Old February 1st, 2007, 05:23 PM
Registered User
 
Join Date: Feb 2007
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Noob # 2 here to register the same issue - it ain't working for me either. My response says "this error occured while loading the following files: application.rb"
Wish I could give you your answer. If I figure it out, or am fortunate enough to have a white night respond, I'll let you know.
Good luck.

  #3 (permalink)  
Old February 1st, 2007, 08:32 PM
Registered User
 
Join Date: Jan 2007
Location: , , .
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

 
Quote:
quote:Good luck.


Thanks jmuckle.
I've just continued on with the book - haven't had the problem repeat itself fortunately. I wonder if I did a typo.
Good luck to you too!



Similar Threads
Thread Thread Starter Forum Replies Last Post
Very first "greeting" app not working cothedo BOOK: Beginning Ruby on Rails 3 December 6th, 2008 01:04 AM
Chapter 8 - app.config jotto BOOK: Beginning Visual Basic 2005 Databases ISBN: 978-0-7645-8894-5 2 March 21st, 2006 05:31 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.