Wrox Programmer Forums
|
BOOK: Beginning Ruby on Rails
This is the forum to discuss the Wrox book Beginning Ruby on Rails by Steve Holzner Ph.D.; ISBN: 9780470069158
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Beginning Ruby on Rails section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old December 21st, 2007, 05:23 PM
Registered User
 
Join Date: Dec 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Newbie problems

I have ground to a halt on page 2!! I have downloaded and installed Ruby (Windows XP) no problem. When I try to install Rails with:
gem install rails --include-dependencies
I get the message:
'gem' is not recognized as an internal or external command, operable program or batch file.

Any ideas as to what I'm doing wrong? Thanks!

 
Old January 3rd, 2008, 07:09 AM
Friend of Wrox
 
Join Date: Dec 2003
Posts: 488
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Did you install rubygems like this?

" 3.1 Installing RubyGems

Get it from RubyForge (http://rubyforge.org/frs/?group_id=126) and run (as root, if appropriate and necessary)

ruby setup.rb

It’s easy. It installs the required library files and the gem command. This command gives us the power to do everything else in this document, except distribute gems (for now!)."

From gem manual at:

http://rubygems.org/read/chapter/3




--
Charlie Harvey's website - linux, perl, java, anarchism and punk rock: http://charlieharvey.org.uk
 
Old February 7th, 2008, 06:15 AM
Registered User
 
Join Date: Feb 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got the exact same problem, and the fix is quite simple (but I have no idea why it works). Install rake.
Code:
gem install rake
when it finishes
Code:
gem install rails --include-dependencies
and that should work.






Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Help Newbie aduggan Classic ASP Databases 19 April 3rd, 2007 03:05 PM
this Newbie has adp / stored query problems - LeoTiger1 BOOK: Access 2003 VBA Programmer's Reference 0 June 13th, 2006 03:40 PM
Newbie Help! TheShadow Javascript 1 March 21st, 2005 03:42 AM
newbie needs help, please godsallaroundus VB.NET 1 October 28th, 2004 11:08 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.