Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
BOOK: Beginning Windows Phone 7 Application Development: Building Windows Phone Applications Using S
This is the forum to discuss the Wrox book Beginning Windows Phone 7 Application Development: Building Windows Phone Applications Using Silverlight and XNA by Nick Lecrenski, Karli Watson, Robert Fonseca-Ensor; ISBN: 978-0-470-91233-1
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Beginning Windows Phone 7 Application Development: Building Windows Phone Applications Using S section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old August 3rd, 2011, 06:18 PM
Registered User
 
Join Date: Aug 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default XamlParseException in VisualStates example

Hello; I am really enjoying this book! I do have a question though regarding an exception in the VisualStates project.

Above the designer it says XamlParseException was thrown on "CustomButton": Uknown attribute Text on element TextBlock.

I am receiving this in the error list "Unknown attribute Text on element TextBlock. [Line: 1 Position: 1681] File MainPage.xaml Line 31 Column 13

I receive this message whether I use the code I wrote following along or the files I downloaded from Wrox.
 
Old August 11th, 2011, 01:03 AM
Registered User
 
Join Date: Aug 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That is quite a lot of views to receive no replies . I take it that no one else had this problem. Oh well . Of course I haven't let this issue stop me from moving on in the book but I would like to understand what is going on.
 
Old September 24th, 2011, 04:17 PM
Registered User
Points: 3, Level: 1
Points: 3, Level: 1 Points: 3, Level: 1 Points: 3, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I see the same error.... not sure why. Seems a bit odd because it is pretty simple stuff.
 
Old March 23rd, 2012, 11:52 AM
bmw bmw is offline
Registered User
Points: 26, Level: 1
Points: 26, Level: 1 Points: 26, Level: 1 Points: 26, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default The error basically said “Value was Out of Range”.

I had the same problem and searched the solution. I found the document to indicate that the error basically said “Value was Out of Range”. However I tried to adjust the size of the button and still got the error.
The following link is explanation for this error.

http://blog.davidyack.com/journal/20...your-size.html








Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.