Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
BOOK: Professional Microsoft Office SharePoint Designer 2007 ISBN: 978-0-470-28761-3
This is the forum to discuss the Wrox book Professional Microsoft Office SharePoint Designer 2007 by Woodrow W. Windischman, Bryan Phillips, Asif Rehmani; ISBN: 9780470287613
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Professional Microsoft Office SharePoint Designer 2007 ISBN: 978-0-470-28761-3 section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old June 10th, 2009, 07:04 AM
Registered User
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Workflows in Sharepoint Designer

Hello , I am new to this forum and new to using Sharepoint Designer. I do have experience in ASP.NET , and C# but am looking to minimise the development needed using Visual Studio.

I have set up a test site so I can play around with Workflows etc. the Three Part approval process is working fine on the site , but the Workflows defined using Sharepoint Designer are all saying they have completed but are not doing what they are supposed to. In one instance all the workflow has to do is send an e.mail to a user. I have tried both DOMAIN\USER and the e.mail. I have also checked that the DOMAIN\USER has the e.mail filled as well.

Any pointers on what settings I may be missing will be appreciated.
 
Old June 10th, 2009, 07:19 AM
Authorized User
 
Join Date: Nov 2008
Location: , , USA.
Posts: 17
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Just to clarify, is the workflow functioning other than the email? Is the SharePoint server able to send other emails (e.g. Alerts)?
__________________
- Woody -
 
Old June 10th, 2009, 07:25 AM
Registered User
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the very quick reply. Great book btw.
yes all other e.mails are working fine. If I follow the three part process - submit for approval etc. I get e.mails.
The Workflow I have defined in Sharepoint Designer shows up o.k in the list where I've defined it , it even says it's processing and completed , but doesn't send an e.mail.
I've looked at logs etc. but can't see anything listed.

Just to note I set the site up initially with default settings. All Sites/Subsites are 'publishing with workfolw' but I don;t think the 'Home' site is. Would this affect the workflow.
 
Old June 10th, 2009, 07:44 AM
Authorized User
 
Join Date: Nov 2008
Location: , , USA.
Posts: 17
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Thanks.

It is possible the configuration setting could have an impact. Unfortunately I don't have an evironment set up to try duplicating your issue right now. Can your workflow in that site do anything besides (not) send an email? For example, can you set a field to a value?
__________________
- Woody -
 
Old June 10th, 2009, 07:54 AM
Registered User
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes I just tried that and it worked! I set the Name field to be updated. That completed successfully, but the e.mail was still not sent.
 
Old June 10th, 2009, 08:26 AM
Registered User
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

just to update , I've changed the workflow to
send an e.mail - this doesn't work
change the name of the document - this does
Assign a task - this also works and notifies that the task has been assigned via e.mail.

It looks like it's just the intial e.mail that doesn't work.
 
Old June 10th, 2009, 09:02 AM
Registered User
 
Join Date: Jun 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

just to add.

thanks for your help on this - I have managed to get the workflow to send an e.mail now.

I am testing different e.mail addresses as I think it was connected to that initially. My mail also decided to send some of the e.mails to the Junk folder which is a bit weird as other e.mails from my sharepoint were o.k.

I told you I was new to this
 
Old June 10th, 2009, 09:21 AM
Authorized User
 
Join Date: Nov 2008
Location: , , USA.
Posts: 17
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Glad to hear that everything is working!
__________________
- Woody -




Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Designer to UI Designer jitesh82 BOOK: Beginning CSS: Cascading Style Sheets for Web Design ISBN: 978-0-7645-7642-3 2 April 16th, 2011 01:04 AM
on Crystal designer help..? megana Crystal Reports 5 June 30th, 2006 04:22 PM
Can't see designer code katsarosj ASP.NET 2.0 Basics 1 January 26th, 2006 11:36 PM
Control designer hhuberlant BOOK: Professional ASP.NET 2.0 and Special Edition; ISBN: 978-0-7645-7610-2; ISBN: 978-0-470-04178-9 1 December 22nd, 2005 06:02 PM
report designer madkaikar_ashish Crystal Reports 0 June 29th, 2004 07:05 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.