Wrox Programmer Forums

Need to download code?

View our list of code downloads.

| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
BOOK: Professional SQL Server Reporting Services ISBN: 0-7645-6878-7
This is the forum to discuss the Wrox book Professional SQL ServerReporting Services by Paul Turley, Todd Bryant, James Counihan, George McKee, Dave DuVarney; ISBN: 9780764568787
Welcome to the p2p.wrox.com Forums.

You are currently viewing the BOOK: Professional SQL Server Reporting Services ISBN: 0-7645-6878-7 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
 
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old August 3rd, 2004, 05:42 AM
Registered User
 
Join Date: Aug 2004
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Subreport Problem

Hi, I need your help.
I have report with subreport. Report has one information and if you click to one field I need subreport open and show another information.
I created this report but the problem is User complain that he cannot go back to main report there is no back button inside html viewer.(it exists in design).
I have 2 choices:
1. open subreport in new window
2. create link inside subreport to main report.

1. I couldn't find how to do it. because I need to pass the parameters from main report to subreport in URL string.
2. I created parameters in subreport and pass to them main report param. when I click on the "return to main report" text box it return to main report. but I have 2 issues with this scenario. 1) I need to hide parameters (If I hide them by removing Promt propery and set the default value. when I run report from the main I got error parameter is read-only. 2) If I don't hide them I see the parameters what I don't need but another problem it opens the main report and hide the parameter panel (I am talking about HTML viewer).

Please let me know if you done something simmular.
Thanks a lot.

 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
subreport bib Visual Basic 2005 Basics 0 August 25th, 2006 12:56 AM
problem about refering subreport bbqlee Access 1 July 3rd, 2006 07:37 AM
problem with subreport in CR lpastor Crystal Reports 0 November 17th, 2004 08:46 AM
Cyrstal report subreport problem keshavap Crystal Reports 0 September 24th, 2004 02:29 AM
Subreport problem: ADP + SQL Server pinkandthebrain Access 11 December 9th, 2003 03:15 AM



All times are GMT -4. The time now is 10:59 PM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.