Wrox Programmer Forums
Go Back   Wrox Programmer Forums > C# and C > C++ and Visual C++ > C++ Programming
|
C++ Programming General discussions for the C++ language. For questions specific to Microsoft's Visual C++ variant, see the Visual C++ forum instead.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the C++ Programming section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old March 17th, 2005, 02:30 AM
Registered User
 
Join Date: Mar 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default help:: Prob with DCOM in Win XP

Dear Friends,

in DCOM configuration
do i need to change anything in my project when i use it with windows xp. it works fine with win2000.
in windows xp, at server end i've the project exe running fine. but the component is missing in browser. that way its not accessible to
client programs.
what can be the problem?

thanks in anticipation
regards
Sachin M


Reply With Quote
  #2 (permalink)  
Old March 22nd, 2005, 08:51 AM
Friend of Wrox
 
Join Date: Jun 2003
Posts: 453
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to Ankur_Verma Send a message via MSN to Ankur_Verma
Default

1
How did you get COM server related registry entries written to the registry in 2000. Did you register the COM server Itself or you wrote a registry scipt.

2
Have you done the same on XP?


Regards
Ankur Verma
Reply With Quote
  #3 (permalink)  
Old March 23rd, 2005, 01:28 AM
Registered User
 
Join Date: Mar 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Ankur.
here goes what I did:
1)My team has developed an ATL COM exe project. and a client that will
  get this as a server from other machines. On release build installation package,
  it registers itself on the win 2000 machine.
  and in Component Services -> DCOM configuration we got the exe. further we have
  configured it as per our need, i mean the security, users, location etc.
  and the exe was available for clients.

2)The same procedure we have followed in win XP with service pack 2 and without
  service pack.
  the exe executes individually, no issue.
  but we didn't get it in DCOM configuration, and no configurations can be done.

  we also moved total source code on xp machine, compiled, and build on the same
  xp machine. but no results.

please help.

thanks & regards,
Sachin Malode

Reply With Quote





Similar Threads
Thread Thread Starter Forum Replies Last Post
prob:: vc++ ATL COM exe on win xp sachin_dm Visual C++ 1 March 22nd, 2005 08:49 AM
Prob calling .exe programs on Win XP. iisaphpache Pro PHP 0 May 31st, 2004 06:54 PM
Installing PHP on Win XP how to ? tandhy BOOK: Beginning PHP4/PHP 5 ISBN: 978-0-7645-4364-7; v5 ISBN: 978-0-7645-5783-5 1 April 6th, 2004 12:51 PM
Win '98 vs. Win XP rgerald Access VBA 0 February 19th, 2004 12:30 PM
Win xp Pro + IIS morpheus Access 2 November 21st, 2003 10:19 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.