Wrox Programmer Forums
|
Classic ASP Basics For beginner programmers starting with "classic" ASP 3, pre-".NET." NOT for ASP.NET 1.0, 1.1, or 2.0
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Classic ASP Basics section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old October 11th, 2004, 09:52 AM
Registered User
 
Join Date: Oct 2004
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default FileSystemObject problem...

I am having a problem with the FileSystemObject running on my machine. I'm using WinXp's IIS on a P3 650mhz laptop. Whenever I create an instance of the FileSystemObject, the page just sits there loading. It doesn't time out, it doesn't error out, it just sits there loading. All I have to do is set an object equal to CreateObject("Scripting.FileSystemObject") and the page is doomed. I don't have to do anything more then that. My page could be one line <% Set fso = CreateObject("Scripting.FileSystemObject")%>.

I've been coding ASP for about 5 years and using the FileSystemObject for almost as long and have never encountered this problem before.

Any ideas would be appreciated.

Thank you,

-Michael

 
Old October 12th, 2004, 12:47 AM
Friend of Wrox
 
Join Date: Jun 2003
Posts: 2,480
Thanks: 0
Thanked 1 Time in 1 Post
Default

Did you forget Server all those times or just this time? How about trying that now?
Code:
<% Set fso = Server.CreateObject("Scripting.FileSystemObject")%>
Cheers!

_________________________
- Vijay G
Strive for Perfection
 
Old October 12th, 2004, 02:45 PM
Registered User
 
Join Date: Oct 2004
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

With the FileSystem Object,there is no need for the Server. portion, CreateObject works just fine.

Following Microsoft's example, they don't use it either: http://support.microsoft.com/default...b;en-us;300982

The code works fine live on IIS 6.0 on Windows Server 2003 as well as on IIS 4.0 on Windows NT 4 and PWS on Windows 98SE. I thought maybe there was something quirky with the version of IIS on WinXP.

Just to satisfy your post, adding the Server. doesn't produce results.

Thanks,

-Michael






Similar Threads
Thread Thread Starter Forum Replies Last Post
FileSystemObject not available mega Classic ASP Professional 1 June 19th, 2006 10:25 AM
Need Help about FileSystemObject vbpratap VB.NET 0 March 3rd, 2006 06:40 AM
Using the FileSystemObject malhyp Dreamweaver (all versions) 1 October 2nd, 2005 07:00 AM
I need help with FileSystemObject ... PLEASE xanderxvr Classic ASP Professional 0 January 31st, 2005 02:56 AM
fileSystemObject Problem Blaise Classic ASP Basics 2 August 13th, 2003 08:08 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.