Wrox Programmer Forums
|
Classic ASP Basics For beginner programmers starting with "classic" ASP 3, pre-".NET." NOT for ASP.NET 1.0, 1.1, or 2.0
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Classic ASP Basics section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old February 10th, 2005, 05:26 AM
Friend of Wrox
 
Join Date: Jan 2005
Posts: 1,525
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to crmpicco Send a message via AIM to crmpicco Send a message via MSN to crmpicco Send a message via Yahoo to crmpicco
Default correct syntax?

<%
dim arrStr
dim theStr

theStr = "xmldoc.documentelement.selectnodes("dataElementsM aster").item(0).selectnodes("dataElementsIndiv").i tem(2).selectnodes("miscellaneousRemarks").item(0) .selectnodes("remarks").item(0).selectnodes("freet ext").item(0).text"
response.write "theStr = " & theStr & "<br>"
%>

_________________________________________

I get this error:

Error Type:
Microsoft VBScript compilation (0x800A0401)
Expected end of statement
/mackenzie/asp/mytrip_new.asp, line 477, column 48
theStr = "& xmldoc.documentelement.selectnodes("dataElementsMa ster").item(0).selectnodes("dataElementsIndiv").it em(2).selectnodes("miscellaneousRemarks").item(0). selectnodes("remarks").item(0).selectnodes("freete xt").item(0).text &"
-----------------------------------------------^


www.crmpicco.co.uk
__________________
_______________________
Ayrshire Minis - a Mini E-Community
http://www.ayrshireminis.com
http://www.crmpicco.co.uk
 
Old February 10th, 2005, 05:31 AM
Authorized User
 
Join Date: Aug 2004
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please use "" instead of " for giving double quotes inside a string.


Shibu Narayanan
Software Associates
 
Old February 10th, 2005, 05:32 AM
Friend of Wrox
 
Join Date: Jan 2005
Posts: 1,525
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to crmpicco Send a message via AIM to crmpicco Send a message via MSN to crmpicco Send a message via Yahoo to crmpicco
Default

<%
dim arrStr
dim theStr

theStr = xmldoc.documentelement.selectnodes("dataElementsMa ster").item(0).selectnodes("dataElementsIndiv").it em(2).selectnodes("miscellaneousRemarks").item(0). selectnodes("remarks").item(0).selectnodes("freete xt").item(0).text
'response.write "theStr = " & theStr & "<br>"
arrStr = Split(theStr,",")

for i=0 to Ubound(arrStr)
     response.write "arrStr = " & (arrStr(i)) & "<br>"
next
%>

thats the fix

www.crmpicco.co.uk





Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it correct like this ? tunisiano C# 1 March 7th, 2007 12:22 PM
Correct code stefanocinfo BOOK: Professional PHP 5 ISBN: 978-0-7645-7282-1 2 October 4th, 2006 03:06 AM
pageload is not correct... pc_35 ASP.NET 1.0 and 1.1 Basics 5 September 26th, 2006 09:20 AM
VB6 - Is this syntax correct?? mp3pm VB Databases Basics 11 August 31st, 2006 05:28 AM
Getting correct encoding from a webresponse Jonax VB.NET 0 December 21st, 2004 05:37 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.