Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
Classic ASP Basics For beginner programmers starting with "classic" ASP 3, pre-".NET." NOT for ASP.NET 1.0, 1.1, or 2.0
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Classic ASP Basics section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old August 6th, 2005, 05:10 PM
Registered User
 
Join Date: Aug 2005
Location: Novi Sad, , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Simple problem

This is beginner's problem. When I want to create ASP project in Visual Studio, of course I go to File->New->Project->ASP Web Application and when I click "Ok" for the location "http://localhost/WebApplication1" (which is set by default) I get un message: "HTTP/1.1 500 Internal Server Error". Please tell me what should I do? Is it something about configuration of IIS?

PS. I have active service World Wide Web Publishing
 
Old August 6th, 2005, 06:01 PM
Registered User
 
Join Date: Aug 2005
Location: Novi Sad, , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I reinstalled IIS, but now when I try the same operation as before, I get message that my server version, which is 5.1, doesn't support ASP.net 1.1. Can I upgrade this IIS version, or work with older version of ASP.net? Maybe some other solution?
 
Old August 6th, 2005, 09:38 PM
Friend of Wrox
Points: 6,664, Level: 34
Points: 6,664, Level: 34 Points: 6,664, Level: 34 Points: 6,664, Level: 34
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2004
Location: Sydney, NSW, Australia.
Posts: 1,870
Thanks: 12
Thanked 20 Times in 20 Posts
Send a message via AIM to mat41
Default

FYI You are in the classic ASP area of the forum.

1..Do you have the .net framework installed?

;;;"HTTP/1.1 500 Internal Server Error".
This freindly error. Set you browser to not show friendly errors - Open a browser then - tools/internet options/advanced - now uncheck the box that says show friendly http errors. Run your page, what does your error say now?

Have you run ASP or ASPX pages on this machine before? If not - what happens when you type http://localhost/localstart.asp You should see the IIS help pages, do you?

This should help you:
http://support.microsoft.com/default.aspx?scid=555132


Wind is your friend
Matt
 
Old August 8th, 2005, 10:16 AM
Registered User
 
Join Date: Aug 2005
Location: Novi Sad, , .
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That link helped me, thank you
 
Old August 8th, 2005, 06:14 PM
Friend of Wrox
Points: 6,664, Level: 34
Points: 6,664, Level: 34 Points: 6,664, Level: 34 Points: 6,664, Level: 34
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2004
Location: Sydney, NSW, Australia.
Posts: 1,870
Thanks: 12
Thanked 20 Times in 20 Posts
Send a message via AIM to mat41
Default

Great, google usually has the answers.

Wind is your friend
Matt




Similar Threads
Thread Thread Starter Forum Replies Last Post
Simple != problem akentanaka XSLT 3 October 13th, 2008 11:54 PM
A Simple Problem paole Wrox Book Feedback 7 July 23rd, 2007 08:55 PM
Simple Problem Little Shell XML 2 June 5th, 2006 03:30 PM
a simple problem aquarius XSLT 1 February 27th, 2004 06:17 AM
Simple Problem bsdb3 Java GUI 2 February 5th, 2004 09:05 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.