Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP 3 Classic ASP Active Server Pages 3.0 > Classic ASP Basics
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Classic ASP Basics For beginner programmers starting with "classic" ASP 3, pre-".NET." NOT for ASP.NET 1.0, 1.1, or 2.0
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Classic ASP Basics section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #31 (permalink)  
Old October 10th, 2006, 07:41 AM
Wrox Author
Points: 13,255, Level: 49
Points: 13,255, Level: 49 Points: 13,255, Level: 49 Points: 13,255, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2005
Location: Ohio, USA
Posts: 4,104
Thanks: 1
Thanked 64 Times in 64 Posts
Send a message via AIM to dparsons
Default

Ok, I took a look at that source code and, in all that is logical it should work! =\ Anyway. What I did was I split your upload logic out into another page so now the form action is postData.asp. See if that helps.

What i did notice, in regards to the 404 is that in my original code I set the form action up as 'index.asp' not index1.asp which would *probably* explain your 404 (the page was trying to post to an unknown page).

Let me know.

--Stole this from a moderator

I will only tell you how to do it, not do it for you.
Unless, of course, you want to hire me to do work for you.
Reply With Quote
  #32 (permalink)  
Old October 10th, 2006, 09:30 AM
Authorized User
 
Join Date: Sep 2006
Location: Jax, NC, USA.
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to misskaos
Default

tried it, and it didn't work.

It worked the same way, even as me including postData.asp as a file and putting the uploading there.

I also tried changing the page it was posting to. None of that works.

I did notice that when I click the submit button; whenever my alert boxes come up there is a little caution symbol in the bottom (left-hand) corner of the screen. I can't click on it because the alert box is up and once I push ok the caution symbol goes away.



Toni Burgess
misskaos99@yahoo.com
Reply With Quote
  #33 (permalink)  
Old October 10th, 2006, 11:53 AM
Authorized User
 
Join Date: Sep 2006
Location: , , .
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to misskaos99
Default

I have tried everything. Still no luck. Once I hit the 'submit button' and have a valid filename in there.. the alert box comes up, after i click "ok" it goes to "page not displayed". It's not posting the new information into the database anymore. :( Anything else you think I should try?

Reply With Quote
  #34 (permalink)  
Old October 10th, 2006, 12:10 PM
Wrox Author
Points: 13,255, Level: 49
Points: 13,255, Level: 49 Points: 13,255, Level: 49 Points: 13,255, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2005
Location: Ohio, USA
Posts: 4,104
Thanks: 1
Thanked 64 Times in 64 Posts
Send a message via AIM to dparsons
Default

Are you 100% certain that the form action is referencing a valid page?

Also, if you modifed the javascript to have the alert box pop up that says 'Sending File...' remove it and just call form.submit();

--Stole this from a moderator

I will only tell you how to do it, not do it for you.
Unless, of course, you want to hire me to do work for you.
Reply With Quote
  #35 (permalink)  
Old October 10th, 2006, 01:08 PM
Authorized User
 
Join Date: Sep 2006
Location: Jax, NC, USA.
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to misskaos
Default

Yes. I am 200% sure. I took the alert out, it doesn't do any different (just doesn't show the alert box).

I've disabled "show friendly HTTP" in my internet options so I could get a better error description, but it just gives me the same one.

I just don't understand what the problem is. But being that it is not posting my information, I'm guessing it has something to do with my file upload.

Anything else u think I should try?



Toni Burgess
misskaos99@yahoo.com
Reply With Quote
  #36 (permalink)  
Old October 10th, 2006, 01:28 PM
Wrox Author
Points: 13,255, Level: 49
Points: 13,255, Level: 49 Points: 13,255, Level: 49 Points: 13,255, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2005
Location: Ohio, USA
Posts: 4,104
Thanks: 1
Thanked 64 Times in 64 Posts
Send a message via AIM to dparsons
Default

instead of trying to upload the file, just put in a response.write("sometext") and remove all the other code if that works then it is a problem inside your upload code.

--Stole this from a moderator

I will only tell you how to do it, not do it for you.
Unless, of course, you want to hire me to do work for you.
Reply With Quote
  #37 (permalink)  
Old October 10th, 2006, 01:50 PM
Authorized User
 
Join Date: Sep 2006
Location: Jax, NC, USA.
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to misskaos
Default

Well dude I kept playing with it and playing with it and I finally got it working!! Thank u Jesus! Only thing is I don't know how!! LOL. And just in time too, got another assignment! Thanks a bunch, I owe ya one.... no make that several ;)

Toni Burgess
misskaos99@yahoo.com
Reply With Quote
  #38 (permalink)  
Old October 10th, 2006, 01:55 PM
Wrox Author
Points: 13,255, Level: 49
Points: 13,255, Level: 49 Points: 13,255, Level: 49 Points: 13,255, Level: 49
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2005
Location: Ohio, USA
Posts: 4,104
Thanks: 1
Thanked 64 Times in 64 Posts
Send a message via AIM to dparsons
Default

Consultation services are free (on here anyway) =P You just owe me for the 2 hours of time it took me to rework the code =P

--Stole this from a moderator

I will only tell you how to do it, not do it for you.
Unless, of course, you want to hire me to do work for you.
Reply With Quote
  #39 (permalink)  
Old October 10th, 2006, 02:05 PM
Authorized User
 
Join Date: Sep 2006
Location: Jax, NC, USA.
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to misskaos
Default

gotcha ;)

Toni Burgess
misskaos99@yahoo.com
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IBM AS400 Message Errors to show them in .NET appl julenis SQL Server 2000 2 July 12th, 2006 01:45 PM
IBM AS400 Message Errors to show them in .NET appl julenis C# 0 July 12th, 2006 10:28 AM
DTS, SQL Server, Show PK value in err message zpluug .NET Framework 2.0 7 March 10th, 2006 12:50 AM
how to show a confirmation message? noor ASP.NET 1.0 and 1.1 Basics 10 May 16th, 2005 03:12 AM
I cannot disabled show windows message “internet e woland666 Visual C++ 0 June 28th, 2004 05:35 AM



All times are GMT -4. The time now is 12:40 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.