Wrox Programmer Forums
Go Back   Wrox Programmer Forums > .NET > Other .NET > Crystal Reports
| Search | Today's Posts | Mark Forums Read
Crystal Reports General discussion about Crystal Reports. For discussions specific to the book Professional Crystal Reports for VS.NET, please see the book discussion forum for that book.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Crystal Reports section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old September 5th, 2005, 10:35 AM
ERC ERC is offline
Authorized User
 
Join Date: Jan 2005
Location: West Sussex, , United Kingdom.
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Logon prompt when upgrade to Crystal 11

After upgrading from Crystal 10 to 11 I found that when I tried to run a report (I'm using Visual Studio .NET) i got a database logon prompt.

Didn't find any help on the web and after a painful 3 days of frustration and hair pulling I finally found the answer. Thought I'd log it here to save anyone else from the same fate.

The reason my reports would not run is because I was feeding the data in via 2 XML schemas. I had created a 'General' Schema which contained a table that was generic to all reports - it contained fields such as report subtitle, logo, and other heading details. Every report was linked to this schema. The actual report data was passed in using another schema - a report-specific schema.

This worked fine in Crystal 10 but not in 11. So I had to copy my 'general' table into all other schemas and delete my 'general' schema. So now I have 1 schema per report.

Hope this makes sense and I hope this helps someone!




Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening Word doc gives logon prompt 531823 VBScript 2 June 26th, 2007 02:54 PM
Passing parameters w/o prompt to Crystal Reports VannAustin BOOK: Professional Crystal Reports for VS.NET 1 August 31st, 2006 08:46 AM
Passing parameters w/o prompt to Crystal reports VannAustin VB How-To 0 March 2nd, 2005 02:16 AM
how to not showing Crystal Report Parameter prompt use4forums BOOK: Professional Crystal Reports for VS.NET 0 April 27th, 2004 07:16 AM
Datasource + logon prompt jeroenjmdejong Crystal Reports 0 November 12th, 2003 09:21 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.