Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Dreamweaver (all versions) section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old February 20th, 2006, 06:01 PM
Registered User
 
Join Date: Feb 2006
Location: State College, PA, USA.
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Images not displaying

Good afternooon: I am creating a website using Dreanweaver. I set up a template and most subsequent pages are off of this template. When I view any page in IE all images on the page show correctly.

When a traverse to the pages in IE from the homepage by clicking on a button on the navigation bar, the images are replaced a red x.

I am confused and do not know where to negin to troubleshoot.

Please! Any assistance will be greatly appreciated.

Penn

Penn
  #2 (permalink)  
Old February 21st, 2006, 05:21 AM
Imar's Avatar
Wrox Author
Points: 70,322, Level: 100
Points: 70,322, Level: 100 Points: 70,322, Level: 100 Points: 70,322, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

Can you post some of the HTML code and describe your setup in some detail? E.g. where are the images located, how do the paths to the images look like, where are the pages located etc...

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
  #3 (permalink)  
Old February 21st, 2006, 11:20 AM
Registered User
 
Join Date: Feb 2006
Location: State College, PA, USA.
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Imar: I appreciate you responding to my post. I figured out the problem. I had the buttons and the paths set at site root in the navigation bar. I changed that to Document and all is functioning properly.

Once again, thank you. However, I can not get the down sate of the button image to display when you navigate to a page.

Is there an easy way to do have the down image activate when you are ona particular page?

Penn
  #4 (permalink)  
Old February 21st, 2006, 12:59 PM
Imar's Avatar
Wrox Author
Points: 70,322, Level: 100
Points: 70,322, Level: 100 Points: 70,322, Level: 100 Points: 70,322, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

It depends on how you set the downstate.

You could, for example, use some JavaScript that is executed on the body's onload event to set the right image.

You can also use CSS on each page to change the (background) image of the selected button.

Can you show some code for your current images?

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.


Similar Threads
Thread Thread Starter Forum Replies Last Post
displaying images chandan121 JSP Basics 0 May 1st, 2008 09:59 PM
Displaying images...... kethireddy435 ASP.NET 2.0 Professional 0 September 16th, 2007 09:25 PM
displaying images and information cherniin J2EE 0 April 23rd, 2007 01:12 AM
Displaying Images From Database Metalore BOOK: Beginning ASP.NET 2.0 and Databases 1 November 1st, 2006 11:45 AM
Displaying images inbox Classic ASP XML 2 May 4th, 2005 03:08 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.