Wrox Programmer Forums
|
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Dreamweaver (all versions) section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old March 10th, 2006, 07:15 AM
Authorized User
 
Join Date: Jan 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default 404 File not found error

We have a dedicated windows 2000 server with IIS 5.0.
I have set up a web site in dreamweaver and FTP the web site files to the server.When the main page is loaded it loads up fine, but as soon as you submit the page it comes up with the following error"404 FILE NOT FOUND INTERNET INFORMATION SERVICES".
The web site has works fine on my local webserver on my pc that has IIS installed as well.

The web pages are .asp by the way.

Is there something in IIS on the server that needs configuring that i have missed because i have checked loads of settings and can't get it to work.

Thanks

Jayman

 
Old March 10th, 2006, 05:10 PM
Imar's Avatar
Wrox Author
 
Join Date: Jun 2003
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

Hi there,

How does the structure of your site look like? On your local machine, do you access it like http://localhost?

Do you see anything in the final HTML source in the browser that looks odd? E.g. hardcoded links to http://localhost for example?

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
 
Old March 13th, 2006, 07:16 AM
Authorized User
 
Join Date: Jan 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

No everything is the same on local server as on the web server.
There's no mysterious html code or hardcoded links.

It's almost like when you are on the actual web server and type in the main page, the server can't find it.
So it's like the server can't find the route to my website files on the server.

Jayman



Quote:
quote:Originally posted by Imar
 Hi there,

How does the structure of your site look like? On your local machine, do you access it like http://localhost?

Do you see anything in the final HTML source in the browser that looks odd? E.g. hardcoded links to http://localhost for example?

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
 
Old March 13th, 2006, 12:59 PM
Authorized User
 
Join Date: Jan 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's ok I managed to fix the problem by re-installing IIS on windows 2000 server.

Jayman



Quote:
quote:Originally posted by Imar
 Hi there,

How does the structure of your site look like? On your local machine, do you access it like http://localhost?

Do you see anything in the final HTML source in the browser that looks odd? E.g. hardcoded links to http://localhost for example?

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.





Similar Threads
Thread Thread Starter Forum Replies Last Post
HTTPListener Exception and 404 Not Found error JanK .NET Web Services 0 June 2nd, 2006 03:56 AM
Resource not found - HTTP -404 javz_1 Apache Tomcat 1 January 16th, 2006 05:35 AM
ERROR: HTTP 404 File not Found or unable to stat f rpk BOOK: Beginning PHP, Apache, MySQL Web Development ISBN: 978-0-7645-5744-6 1 January 4th, 2006 10:20 PM
404 - File not found error geeta Classic ASP Professional 1 October 23rd, 2004 09:25 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.