Wrox Programmer Forums
| Search | Today's Posts | Mark Forums Read
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Dreamweaver (all versions) section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old February 15th, 2004, 11:35 PM
Authorized User
 
Join Date: Feb 2004
Location: Nashville, TN, USA.
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Color picker problem

Has anyone else had trouble with the color picker in MX and MX 2004? In Dreamweaver 3 and UltraDev 4, when using the picker to choose a non-web-safe color you could always open up the picker again and the existing color would still be chosen. In MX and MX 2004 it opens back up to pure white, and I have to guess where I was.

Anyone with similar trouble or recommendations? Thanks in advance.

__________________
__________________________________________________ _____________

Confidence is what you feel when you do not truly understand the situation.
  #2 (permalink)  
Old February 16th, 2004, 03:34 AM
Imar's Avatar
Wrox Author
Points: 70,322, Level: 100
Points: 70,322, Level: 100 Points: 70,322, Level: 100 Points: 70,322, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

Can you elaborate on this a bit? How and where do you select a color, and where do you expect it to be selected again? I can imagine that if the Color Picker doesn't show your color in one of the grids, it also can't preselect it.....

Cheers,

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
  #3 (permalink)  
Old February 16th, 2004, 11:50 AM
Authorized User
 
Join Date: Feb 2004
Location: Nashville, TN, USA.
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Screen shot (51K): http://www28.brinkster.com/dmn23/colorpicker.jpg

In this example, I've decided the hex color #A93210 wasn't exactly what I wanted. When I reopen the color picker, the crosshairs have defaulted to white instead of the hue corresponding to #A93210. It wasn't this way in previous versions. What gives?

Thanks,

- abq23

------------------------------------------------------------------------

Confidence is what you feel when you do not truly understand the situation.
  #4 (permalink)  
Old February 16th, 2004, 02:04 PM
Imar's Avatar
Wrox Author
Points: 70,322, Level: 100
Points: 70,322, Level: 100 Points: 70,322, Level: 100 Points: 70,322, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

Yeah, I see what you mean now.

Looks like a bug to me especially because it indeed doesn't occur in DW MX on the same platform.....

Funny things is, right after I tried it in MX, I tried it in 2004 again, and now I can no longer reproduce it anymore. That is, the color picker *does* select the right color. Do you have any steps that always allow you to reproduce this?

Cheers,

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
  #5 (permalink)  
Old February 16th, 2004, 06:33 PM
Authorized User
 
Join Date: Feb 2004
Location: Nashville, TN, USA.
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Unfortunately, there's no isolated set of circumstances where this occurs. It happens all the time (at home and at work). Both machines are running XP Professional. I was just curious as to whether this was a known bug and if there were any fixes or workarounds. Thanks for taking the time to review my inquiry, though.

- abq23

------------------------------------------------------------------------

Confidence is what you feel when you do not truly understand the situation.
  #6 (permalink)  
Old February 17th, 2004, 05:08 AM
Imar's Avatar
Wrox Author
Points: 70,322, Level: 100
Points: 70,322, Level: 100 Points: 70,322, Level: 100 Points: 70,322, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

Yeah, it's very odd and it seems to occur randomly. I can no longer reproduce it....

If you do find a way to reproduce it consistently, please let me know.

Cheers,

Imar


---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.
  #7 (permalink)  
Old June 2nd, 2004, 11:25 AM
Registered User
 
Join Date: Jun 2004
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Sander
Default

Hey guys.. i'm having the same problem, working on WXP platform, and using DW MX 2004 (2003 version).

Every time i try to edit the color opening the color picker, the selected color isn't the right one, but only White.

Did you already find any fix for this problem?

PS: Using the same feature in Flash MX 2004 is ok. So strange... :-|

Hope u can help me ;)

Email: sandro@portasabertas.org.br
  #8 (permalink)  
Old June 2nd, 2004, 12:11 PM
Imar's Avatar
Wrox Author
Points: 70,322, Level: 100
Points: 70,322, Level: 100 Points: 70,322, Level: 100 Points: 70,322, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Utrecht, Netherlands.
Posts: 17,089
Thanks: 80
Thanked 1,576 Times in 1,552 Posts
Default

Hi Sander,

I haven't seen a fix for this issue, but did you upgrade to version 7.01? That version has a lot of bug fixes, so maybe this one was included as well.

Cheers,

Imar
---------------------------------------
Imar Spaanjaars
Everyone is unique, except for me.


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with color of listitems when postback hertendreef ASP.NET 2.0 Professional 6 March 9th, 2008 11:00 AM
Web Custom Control - Color Picker Property elwappo ASP.NET 2.0 Professional 0 January 31st, 2008 08:37 AM
problem with dateTime picker roy_mm Reporting Services 2 March 14th, 2007 11:34 AM
how to add color picker in datagrid? param99 ASP.NET 1.0 and 1.1 Professional 1 November 9th, 2006 03:57 AM
DateTime Picker sconineuk VB.NET 2002/2003 Basics 2 March 9th, 2006 01:09 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.