Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Web Programming > HTML > HTML Code Clinic
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
HTML Code Clinic Do you have some HTML code you'd like to share and get suggestions from others for tweaking or improving it? This discussion is the place.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the HTML Code Clinic section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old April 13th, 2005, 12:02 AM
Registered User
 
Join Date: Apr 2005
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to splinterz
Default iframe help

hi, has anyone had problems loading large images into iframes before? i've been trying to load some large images from thumbnails, but the iframs are only displaying half, and sometimes even less of the image indside of the iframe...any help would be much appreciated, thanks.



Reply With Quote
  #2 (permalink)  
Old April 13th, 2005, 12:19 AM
Friend of Wrox
Points: 1,315, Level: 14
Points: 1,315, Level: 14 Points: 1,315, Level: 14 Points: 1,315, Level: 14
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: , , .
Posts: 425
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Well, is the iframe big enough to display the whole image? :)

(o<
//\ =^..^=
Reply With Quote
  #3 (permalink)  
Old April 13th, 2005, 12:22 AM
Registered User
 
Join Date: Apr 2005
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to splinterz
Default

well it just kind of grows on it's own cause it has scroll bars...

Reply With Quote
  #4 (permalink)  
Old April 13th, 2005, 12:40 AM
Friend of Wrox
Points: 1,315, Level: 14
Points: 1,315, Level: 14 Points: 1,315, Level: 14 Points: 1,315, Level: 14
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: , , .
Posts: 425
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Oh, sorry.

You mean you can't see the while image even if you scroll? It really doesn't load fully? No, I've never seen that. Could you show a sample page maybe?

(o<
//\ =^..^=
Reply With Quote
  #5 (permalink)  
Old April 13th, 2005, 12:40 AM
Registered User
 
Join Date: Apr 2005
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to splinterz
Default

and that was a very bad explanation....what i mean is that the width and height are set to 100% and the scrollbars to auto. it's just strange because it's only SOME images that don't display properly, and other images are all pixilated...

Reply With Quote
  #6 (permalink)  
Old April 13th, 2005, 12:48 AM
Friend of Wrox
Points: 1,315, Level: 14
Points: 1,315, Level: 14 Points: 1,315, Level: 14 Points: 1,315, Level: 14
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: , , .
Posts: 425
Thanks: 0
Thanked 3 Times in 3 Posts
Default

And if you load the framed page on it's own? Are the images still pixelated? Could you have uploaded them in ASCII mode?

(o<
//\ =^..^=
Reply With Quote
  #7 (permalink)  
Old April 13th, 2005, 01:01 AM
Registered User
 
Join Date: Apr 2005
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to splinterz
Default

no the framed page on it's own loads fine...i tried with a few other images to see and they're fine too...

Reply With Quote
  #8 (permalink)  
Old April 13th, 2005, 01:01 AM
Registered User
 
Join Date: Apr 2005
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to splinterz
Default

*sigh* wtf am i talking about, fine = not loading ...

Reply With Quote
  #9 (permalink)  
Old April 13th, 2005, 01:12 AM
Friend of Wrox
Points: 1,315, Level: 14
Points: 1,315, Level: 14 Points: 1,315, Level: 14 Points: 1,315, Level: 14
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: , , .
Posts: 425
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Now I'm confused... The images are corruped? :D

(o<
//\ =^..^=
Reply With Quote
  #10 (permalink)  
Old April 13th, 2005, 01:20 AM
Registered User
 
Join Date: Apr 2005
Location: , , .
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to splinterz
Default

ok if i take other images (not uploaded ones) they also do not load completely. if i run the page that only has the large image in it, everything is ok. if i run it in an iframe, the image loads all messed up again. am i making sense yet? :)

Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to get out from Iframe k.manisha ASP.NET 2.0 Professional 1 September 12th, 2007 12:20 PM
values from one iframe to another iframe URGENT raaj Beginning PHP 2 February 27th, 2007 12:19 PM
iFrame fyp4135 ASP.NET 2.0 Basics 0 October 5th, 2006 11:32 AM
iframe rockon HTML Code Clinic 1 March 2nd, 2005 06:00 AM
iframe...or a better way? stacy HTML Code Clinic 4 September 4th, 2004 11:04 AM



All times are GMT -4. The time now is 02:07 AM.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.