Wrox Programmer Forums
|
HTML Code Clinic Do you have some HTML code you'd like to share and get suggestions from others for tweaking or improving it? This discussion is the place.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the HTML Code Clinic section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old September 5th, 2006, 11:58 AM
Authorized User
 
Join Date: Aug 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Firefox issue

Hi guys, can anyone spot why the quick search form does not work on this website ive been working on, works fine in I.E, just not Firefox and presumably other browsers.

This is my first bit of real work so apologies for the code not always being the best, still got lots to learn about web standards (among other things!).

http://www.thedateoutdoors.com

ps i should also add that this is indeed a dating site, probably should have started my freelance career with a smaller project!

Cheers, Will

 
Old September 5th, 2006, 12:08 PM
Authorized User
 
Join Date: Aug 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ps sorry for being a nuisance, i should point out that the div to look for in the source code is <div id="#psearch">
If anyone can spot anything please let me know

Thanks in advance

Will

 
Old September 5th, 2006, 12:08 PM
Friend of Wrox
 
Join Date: Jun 2003
Posts: 425
Thanks: 0
Thanked 3 Times in 3 Posts
Default

My guess is it doesn't work because you have turned JavaScript off in FireFox because it works for me.

It seems unnecessary to make a from that uses a server-side script rely on JavaScript. What's wrong with a submit button?

--
http://yupapa.com
 
Old September 5th, 2006, 12:10 PM
Authorized User
 
Join Date: Aug 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll look into that then.

Im with you on the button thing, the client wanted a text link though for some reason.

 
Old September 5th, 2006, 12:17 PM
Authorized User
 
Join Date: Aug 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the suggestion, i checked firefox but javascript was enabled, i used similar code in the event search as well and it seems to work fine in firefox.

So im not sure what the problem is to be honest. Must be missing something pretty obvious i guess.

 
Old September 5th, 2006, 12:25 PM
Friend of Wrox
 
Join Date: Jun 2003
Posts: 425
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Sorry, then I don't know. If it isn't bug in the version if FF you use.
About the submit link, you can style a button to look like a link. Not in all browsers but...

--
http://yupapa.com
 
Old September 20th, 2006, 03:32 AM
Registered User
 
Join Date: Mar 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey it worked for me in Firefox.
You should upgrade your firefox.





Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox issue timeout08 Dreamweaver (all versions) 2 September 29th, 2008 02:55 PM
DREAMWEAVER/FIREFOX ISSUE PSRIGLEY Dreamweaver (all versions) 9 May 24th, 2008 11:37 AM
Dreamweaver 4 - Firefox issue okayfine Dreamweaver (all versions) 5 June 26th, 2007 02:21 AM
MasterPage and Firefox issue! bignermo BOOK: Professional ASP.NET 2.0 and Special Edition; ISBN: 978-0-7645-7610-2; ISBN: 978-0-470-04178-9 0 May 22nd, 2007 09:20 AM
Firefox v. IE CrystalReportViewer Issue melbsurfer Crystal Reports 1 October 20th, 2006 09:31 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.