Wrox Programmer Forums
Go Back   Wrox Programmer Forums > Java > Java and JDK > J2EE
|
J2EE General J2EE (Java 2 Enterprise Edition) discussions. Questions not specific to EE will be redirected elsewhere.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the J2EE section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old August 25th, 2005, 12:38 AM
Authorized User
 
Join Date: Apr 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default J2EE 1.3 AND FedoraCore 4 j2ee -verbose

Hello guys
(sorry for my grammar)

i have already installed j2ee1.4 in FC4 (without update) and works
but the j2ee1.3.1 dont work (dont start the server)

my same steps or configuration was used in FC1 and 3, but i dont know why here in FC4 i can`t, (tomcat 5.5.9, j2me works fine, note appart of course)

(note in the old version of fedora's i worked with both j2ee, but never in the same time (started both of course) )

here i put the error messages
[root@localhost j2sdkee1.3.1]# cd bin
[root@localhost bin]# j2ee -verbose
J2EE server listen port: 1050
Naming service started:1050
org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
        at com.sun.corba.ee.internal.iiop.ConnectionTable.get Connection(ConnectionTable.java:176) at com.sun.corba.ee.internal.iiop.ConnectionTable.get Connection(ConnectionTable.java:68)
        at com.sun.corba.ee.internal.iiop.GIOPImpl.getConnect ion(GIOPImpl.java:70)
        at com.sun.corba.ee.internal.corba.ClientDelegate.cre ateRequest(ClientDelegate.java:641)
        at com.sun.corba.ee.internal.corba.ClientDelegate.cre ateRequest(ClientDelegate.java:583)
        at com.sun.corba.ee.internal.corba.InitialNamingClien t.resolve(InitialNamingClient.java:1007)
        at com.sun.corba.ee.internal.corba.InitialNamingClien t.resolveUsingBootstrapProtocol(InitialNamingClien t.java:690)
        at com.sun.corba.ee.internal.corba.InitialNamingClien t.cachedInitialReferences(InitialNamingClient.java :1088)
        at com.sun.corba.ee.internal.corba.InitialNamingClien t.resolve_initial_references(InitialNamingClient.j ava:981)
        at com.sun.corba.ee.internal.corba.ORB.resolve_initia l_references(ORB.java:2425)
        at com.sun.enterprise.naming.SerialContextProviderImp l.initSerialContextProvider(SerialContextProviderI mpl.java:37)
        at com.sun.enterprise.server.J2EEServer.run(J2EEServe r.java:233)
        at com.sun.enterprise.server.J2EEServer.main(J2EEServ er.java:972)
java.rmi.RemoteException
        at com.sun.enterprise.naming.SerialContextProviderImp l.initSerialContextProvider(SerialContextProviderI mpl.java:46)
        at com.sun.enterprise.server.J2EEServer.run(J2EEServe r.java:233)
        at com.sun.enterprise.server.J2EEServer.main(J2EEServ er.java:972)
java.rmi.RemoteException
        at com.sun.enterprise.naming.SerialContextProviderImp l.initSerialContextProvider(SerialContextProviderI mpl.java:46)
        at com.sun.enterprise.server.J2EEServer.run(J2EEServe r.java:233)
        at com.sun.enterprise.server.J2EEServer.main(J2EEServ er.java:972)

java.lang.RuntimeException
        at com.sun.enterprise.server.J2EEServer.run(J2EEServe r.java:346)
        at com.sun.enterprise.server.J2EEServer.main(J2EEServ er.java:972)
Error executing J2EE server ...
[root@localhost bin]#

my bashrc
PATH="$PATH:/home/Section1/usrs1/java/jdk1.5.0_01/bin:."
export PATH
CATALINA_HOME="/home/Section1/usrs1/tomcat/jakarta-tomcat-5.5.9"
export CATALINA_HOME
JAVA_HOME="/home/Section1/usrs1/java/jdk1.5.0_01"
export JAVA_HOME


and userconfig.sh (in the bin of j2ee)
#bla bla bla
J2EE_CLASSPATH="/home/Section1/usrs1/java/j2sdkee1.3.1"
export J2EE_CLASSPATH
#bla bla
JAVA_HOME="/home/Section1/usrs1/java/j2sdk1.4.2_06"
export JAVA_HOME


i wait for your help
thanks a lot for your time

LIVE AT POMPEII 1972
__________________
LIVE AT POMPEII 1972
 
Old April 16th, 2007, 03:50 AM
Registered User
 
Join Date: Apr 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem. With J2SE 1.3 I got minor code 1398079689. With J2SE 1.4 I got minor code 201.

After googling for an hour or so I found the following link: http://forum.java.sun.com/thread.jsp...sageID=1259558

And that suggests that the firewall is blocking something. When I turned off my firewall, that solved the problem. Try it!





Similar Threads
Thread Thread Starter Forum Replies Last Post
j2ee version laxminarayana1512 JSP Basics 2 November 5th, 2004 06:22 AM
J2ee myharshdesigner J2EE 2 October 21st, 2004 12:16 AM
Help in J2EE ritesh_sinha J2EE 0 March 18th, 2004 05:54 AM
help in J2EE ritesh_sinha J2EE 1 March 18th, 2004 05:46 AM
j2ee shinu Pro JSP 3 March 6th, 2004 05:04 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.