Wrox Programmer Forums

Need to download code?

View our list of code downloads.

Go Back   Wrox Programmer Forums > Visual Basic > VB 6 Visual Basic 6 > Pro VB 6
Password Reminder
Register
| FAQ | Members List | Calendar | Search | Today's Posts | Mark Forums Read
Pro VB 6 For advanced Visual Basic coders working in version 6 (not .NET). Beginning-level questions will be redirected to other forums, including Beginning VB 6.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Pro VB 6 section of the Wrox Programmer to Programmer discussions. This is a community of tens of thousands of software programmers and website developers including Wrox book authors and readers. As a guest, you can read any forum posting. By joining today you can post your own programming questions, respond to other developers’ questions, and eliminate the ads that are displayed to guests. Registration is fast, simple and absolutely free .
DRM-free e-books 300x50
Reply
 
Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old July 31st, 2003, 02:34 PM
Friend of Wrox
 
Join Date: Jul 2003
Location: , , .
Posts: 121
Thanks: 1
Thanked 0 Times in 0 Posts
Default Error Occurred Reading Records

Hi everybody,
I am having the frustrating error when I try to open my Crystal Report on WEB:"Error Occurred Reading Records: Not supported. Details: Cannot obtain error message from server." I am calling the report from the ASP application. The problem occurred after the call session("oRpt").ReadRecords() :

session("oRpt").ReadRecords
If Err.Number <> 0 Then
  Response.Write "Error Occurred Reading Records: " & Err.Description
  Set Session("oRpt") = nothing
  Set Session("oApp") = nothing
  Session.Abandon
  Response.End
Else
  If IsObject(session("oPageEngine")) Then
      set session("oPageEngine") = nothing
  End If
  set session("oPageEngine") = session("oRpt").PageEngine
End If

I am sending one string-parameter to the report. Everything works OK inside the Crystal IDE. I am using ODBC connection to the database from the Crystal Report.

I do not know what is going on??? Could you help me to solve this problem.
Thanks,
      Dmitriy.

Reply With Quote
  #2 (permalink)  
Old July 31st, 2003, 03:47 PM
Friend of Wrox
Points: 7,395, Level: 36
Points: 7,395, Level: 36 Points: 7,395, Level: 36 Points: 7,395, Level: 36
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2003
Location: Capital Federal, , Argentina.
Posts: 2,189
Thanks: 5
Thanked 59 Times in 57 Posts
Send a message via MSN to gbianchi
Default

hi there..

this error happend on a client machine?? maybe they have a lack of needed dlls??

HTH...

Gonzalo Bianchi
Reply With Quote
  #3 (permalink)  
Old August 1st, 2003, 08:55 AM
Friend of Wrox
 
Join Date: Jul 2003
Location: , , .
Posts: 121
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No,
This error I see on the developer PC. My PC has the PWS server.
The most frustrating part is: the other 10 reports I've created same way the last one has been created work OK and I can see them on the WEB without any problems. The only difference I am connecting to the different Access2000 database(wich is located in the same directory), but the DSN has been created properly,because I can run the report from Crystal IDE like I said.
I could not find the similar problem on the Internet!!!
               -Dmitriy


Quote:
quote:Originally posted by gbianchi
 hi there..

this error happend on a client machine?? maybe they have a lack of needed dlls??

HTH...

Gonzalo Bianchi
Reply With Quote
  #4 (permalink)  
Old August 4th, 2003, 09:31 AM
Registered User
 
Join Date: Jun 2003
Location: chennai, tamilnadu, India.
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi! i too got Same Error but i am using Oracle as backend
I just reinstalled oracle and i created the DSN its started working fine.Try It




Failure is not a Defeat it is just a Delay
Reply With Quote
  #5 (permalink)  
Old August 5th, 2003, 08:43 AM
Friend of Wrox
 
Join Date: Jul 2003
Location: , , .
Posts: 121
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi,
I can't use the Oracle as a back-end. I have to use Access 2000.
What is interesting: for the test sake I've created in the Access 97 database same table and same stored procedure I have in Access 2000 database and created new ODBC connection to this "Test" database for the Crystal Report with same set of fields and everything works OK on the WEB. Unfortunately I have to use Access 2000 database. Like I mentioned before I've created about 20 similar and more complicated reports with ODBC connection to Access 97 database and all of them work perfect on the WEB. I do not know if is some difference to display reports on the WEB for Access 97 and Access 2000?
I've found the description of my error("Error Occurred Reading Records: Not supported. Details: Cannot obtain error message from server.") on Crystal Decisions web site(http://support.crystaldecisions.com/...s/c2012700.asp) but it does not applies to my case, because my report getting correct parameter value (I can see this value on the WEB if I live just one field in the report, containing this parameter value). But if I try to add any additional fields, I am getting the error again.
I am completely frustrated????!!!!
               -Dmitriy

Reply With Quote
  #6 (permalink)  
Old August 5th, 2003, 08:54 AM
Friend of Wrox
 
Join Date: Jun 2003
Location: Cardiff, , United Kingdom.
Posts: 231
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try doing what amar suggested, re-create the database.

You do not need to re-install Access because each instance of Access has its own engine. With Oracle on the other hand the software is the engine and all the databases on the computer use the same engine.

Therefore re-creating the Access database will re-create the engine. You said it worked when you created an Access '97 database, so just re-create the Access 2K database.

(I know, I know, the Access engine is not quite as simple as that, however it does get my point across.)

Regards
Owain Williams
Reply With Quote
  #7 (permalink)  
Old August 5th, 2003, 02:06 PM
Friend of Wrox
 
Join Date: Jul 2003
Location: , , .
Posts: 121
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you very mach Owain and Amar!!!!!
I've recreated the Access2000 database completely and all reports from that database finally working. I've tried to Compact and Repair database first but it did not help. Because of this I did like you advised me to do: recreated the database and restored all dependencies (it was a "big fun" to do:D). I do not know what happened with the original database.
Thanks again,
     -Dmitriy :)

Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error occurred during initialization of VM dinesh.choudhary Java Espanol 3 December 10th, 2014 07:54 AM
error occurred... craft Dreamweaver (all versions) 1 November 1st, 2008 04:31 AM
unexpected error has occurred tworkman BOOK: ASP.NET Website Programming Problem-Design-Solution 20 July 1st, 2007 09:49 PM
error occurred when programmatically compile ramehs2006 C# 2005 0 October 3rd, 2006 04:36 AM
error:Exception occurred hastikeyvan Classic ASP Professional 1 September 13th, 2006 04:40 AM



All times are GMT -4. The time now is 09:43 AM.


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
© 2013 John Wiley & Sons, Inc.