Wrox Programmer Forums
Go Back   Wrox Programmer Forums > XML > XSLT
|
XSLT General questions and answers about XSLT. For issues strictly specific to the book XSLT 1.1 Programmers Reference, please post to that forum instead.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the XSLT section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old June 13th, 2006, 03:20 AM
Authorized User
 
Join Date: May 2006
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default img not refreshing

Hi i have a problem below is the code generated using an xsl
Code:
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:fo="http://www.w3.org/1999/XSL/Format">
 
    <xsl:output method="html"/>

    <xsl:template match="/Root">
        <xsl:for-each select="Graphs">
            <xsl:for-each select="Graph">
                <img src="/contextName/servlet/chartservlet?type={GraphType}&graph={Image}" />
                afsd
            </xsl:for-each>
        </xsl:for-each>
    </xsl:template>
</xsl:stylesheet>
As u see i call a servlet which actually loads the image.

The first time my jsp page loads it works now the next time i try to change the values of the graph and submit to generate a new graph, the xsl loads the image tag but does not call the chartservlet. can u please tell me why this happens and how to solve it

Thanks a mil



 
Old June 13th, 2006, 03:55 AM
mhkay's Avatar
Wrox Author
 
Join Date: Apr 2004
Posts: 4,962
Thanks: 0
Thanked 292 Times in 287 Posts
Default

It's not a problem with your XSLT code, so I can't help you much. Check first whether the XSLT code is generating the correct HTML, then check whether the browser is loading the new version of the HTML.

Michael Kay
http://www.saxonica.com/
Author, XSLT Programmer's Reference and XPath 2.0 Programmer's Reference





Similar Threads
Thread Thread Starter Forum Replies Last Post
Img doesn't display peter2004 HTML Code Clinic 9 September 16th, 2009 08:20 PM
<img> from database... How?? arganaz ASP.NET 2.0 Basics 3 November 20th, 2006 06:58 AM
img tag not loading austinf XSLT 0 June 13th, 2006 04:41 AM
refreshing XML withour refreshing the page sasidhar79 XML 1 January 12th, 2005 05:16 AM
Align IMG with text Snib HTML Code Clinic 12 April 8th, 2004 10:16 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.