Wrox Programmer Forums
Go Back   Wrox Programmer Forums > Microsoft Office > Access and Access VBA > Access
|
Access Discussion of Microsoft Access database design and programming. See also the forums for Access ASP and Access VBA.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Access section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old December 10th, 2003, 09:02 AM
Registered User
 
Join Date: Jun 2003
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ODBC Linked Table shows #Deleted in all fields

I'm trying to create a front end in MS Access 97 for a SQL Server 2000 Database.

If I create a pass-thru query to my table, I see records. If I create a linked table using ODBC, every field of every record shows #Deleted.

What am I doing wrong? I haven't worked with databases in a while.

Thanks in advance.

8^D
Darron
 
Old December 10th, 2003, 11:18 PM
Friend of Wrox
 
Join Date: Nov 2003
Posts: 625
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to jemacc
Default

you may want to check the back tables and see if one of those tables has triggers trying to update, insert, delete, while another is trying to do the same.

 
Old December 15th, 2005, 07:09 PM
Authorized User
 
Join Date: Dec 2004
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I saw similar occurance. In Access 2000, I used the linked table manager to renew the link to the ODBC db table, which fixed the problem. In Access97, one would have to delete the linked table (delete the link, not the table, then link the table again. If deleting the link, be sure to note the name of the table in Access, so the same name can be restored after new link is made.

JK
 
Old December 16th, 2005, 01:49 AM
Friend of Wrox
 
Join Date: Jun 2003
Posts: 1,093
Thanks: 1
Thanked 12 Times in 11 Posts
Default

MS has a KB article on the issue at:

http://support.microsoft.com/kb/q128809/

 
Old December 16th, 2005, 03:00 PM
Authorized User
 
Join Date: Dec 2004
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

>> MS has a KB article on the issue at:
>> http://support.microsoft.com/kb/q128809/


The article states "..If you close and re-open the table ... the deleted errors are removed"
But when I saw it, closing table and reopening did not fix. Closing access and reopening did not fix.

...applies to Access 97
I saw it in Access 2k.


JK





Similar Threads
Thread Thread Starter Forum Replies Last Post
ODBC linked table showing old data (not refreshing d-fxt Access 3 November 14th, 2007 05:56 PM
ODBC - insert on a linked field - [microsoft][ODBC chimp MySQL 0 April 7th, 2005 04:44 AM
Deleted Printers Table Teqlump Access VBA 1 September 10th, 2004 05:50 PM
Data has changed error with linked ODBC table Wim Leys Access 7 June 8th, 2004 06:05 AM
Access - Linked ODBC Tables Ben Access 0 July 24th, 2003 10:39 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.