Wrox Programmer Forums
|
All Other Wrox Books Do you have a question about a Wrox book that isn't listed anywhere on p2p.wrox.com or where the forum is locked? Here's a forum to post questions about any other Wrox book so that other readers or one of the authors can help you with your questions. IF YOU ARE LOOKING FOR CODE DO NOT ASK "Where can I find the code for this book?" That question is answered here.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the All Other Wrox Books section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old August 3rd, 2003, 11:16 PM
Registered User
 
Join Date: Aug 2003
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default PHP MySQL Website Programming P-D-S

I have finished building the base user and session architecture. After determining the correct base data setup I now can login in
and out of the CMS User admin page.

When I try to submit the password reminder i get the following
error:-

Fatal error: Call to undefined function: send() in /home/virtual/site29/fst/var/www/html/html_new/_lib/_classes/class.users.php on line 185

this is similar to an error I had with DB.php and the ->query()
function.. I managed to resolve that error by fixing my connect
string to MySql in config.php.

Am I missing a similar config item which sets up the path to
sendmail?

please help!

Rob.



  #2 (permalink)  
Old August 5th, 2003, 01:29 AM
Registered User
 
Join Date: Aug 2003
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have fixed the undefined error on send(). Had not set
the mail type for PEAR correctly
 changed Mail::factory("mail");
 to Mail::factory("sendmail");

Now everthing works EXCEPT the activate & deactivate buttons on
/core/users/index.php!

The actual activation/deactivation action and database updates
work correctly. It is when the _notifyUser() is called from
within the activate/deactivate through /core/users/index.php

I get the following error:-
Fatal error: Call to a member function on a non-object in /_lib/_classes/class.users.php on line 188


I noticed that /core/users/index.php instantiated the
class.session.php (which extends class.users.php) through
the tpl_secure.php page.

The _notifyUser() function DOES work.
/site/login/reminder.php
/core/users/form.php
these instantiate class.user.php directly and work!

The _notifyUser() function DOES NOT work
/core/users/index.php

confused? I am!

can anyone help me?






Similar Threads
Thread Thread Starter Forum Replies Last Post
php-mysql website - problem design solution pannet1 Pro PHP 0 December 23rd, 2005 01:49 PM
PHP MySQL Website Programming pugwash All Other Wrox Books 1 December 13th, 2003 10:53 AM
PHP MySQL Website Programming - Where is it? matius All Other Wrox Books 1 August 14th, 2003 11:13 AM
PHP MySQL Website Programming dudu Wrox Book Feedback 3 August 10th, 2003 12:17 PM
PHP MySQL Website Programming P-D-S vicsam All Other Wrox Books 1 July 27th, 2003 08:52 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.