Wrox Programmer Forums
Go Back   Wrox Programmer Forums > Java > Java Open Source > Apache Tomcat
|
Apache Tomcat General discussion of the Apache Tomcat servlet container. For discussions specific to the Professional Apache Tomcat book, please see the book discussion forum for that book.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Apache Tomcat section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old February 18th, 2009, 05:18 AM
Registered User
 
Join Date: Feb 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default 404 Error's Code on Tomcat/Eclipse

Hi everybody,
sorry for my english leanguage but I'm an intalian guy.

I've a problem with Tomcat.

Problem:
I've a web application http://localhost:8080/mywebapplication/
if I put in http://localhost:8080/mywebapplicati...hoto/photo.jpg
a photo the resource is not accessible, BUT if I refresh a folder in Eclipse and after I open the link with Firefox it work.
Why????
I hope you understand me.

in italiano.. ;)
Salve a tutti ho un'applicazione già deployata e funzionante al 100%.
Il problema è che dopo un upload di una foto in una determinata directory (sotto webContent/fileUpload) la risorsa non è accessibile (attraverso il browser), ma se vado sotto eclipse e "refresho" la cartella allora va tutto bene. La stessa cosa succede se io "fisicamente" con esplora risorse di WinXp accedo alla directory, copio e incollo una foto, con il browser non è accessibile ma se faccio un reload in eclipse riesco a vederla...mahh!

Best regards...
Grazie a tutti..
 
Old March 5th, 2009, 03:24 AM
Friend of Wrox
 
Join Date: Mar 2007
Posts: 373
Thanks: 0
Thanked 1 Time in 1 Post
Default

I think its clearly a deployment problem, check the war file of your application whether it includes this image or not [You can use winzip or winrar to open it] if not then check the war file generation script. As you said when you refresh the directory the image is available means that eclipse is doing hot deployment, i mean eclipse checks updated files and overwrites the existing deployed files in tomcat.

Hope it gives a way to find your problem!
__________________
- Rakesh
http://iam-rakesh.blogspot.com





Similar Threads
Thread Thread Starter Forum Replies Last Post
Debug tomcat + eclipse !!! nobitavn94 Apache Tomcat 1 September 27th, 2007 12:02 PM
Topic: jdk5.0 with tomcat 5.5 error 404 carla Apache Tomcat 2 April 13th, 2006 01:36 AM
Using the framework code/ear in Eclipse gvimalku BOOK: Expert One-on-One J2EE Design and Development 2 November 5th, 2005 05:09 AM
Problems with BoxOffice / Eclipse / Tomcat-Sysdeo oops BOOK: Professional Java Development with the Spring Framework 0 October 26th, 2005 11:10 AM
source code examples and Eclipse 3.1.1 keithlhatfield BOOK: Beginning Cryptography with Java 2 October 16th, 2005 07:44 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.