Wrox Programmer Forums
Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP.NET 1.0 and 1.1 > ASP.NET 1.0 and 1.1 Basics
| Search | Today's Posts | Mark Forums Read
ASP.NET 1.0 and 1.1 Basics ASP.NET discussion for users new to coding in ASP.NET 1.0 or 1.1. NOT for the older "classic" ASP 3 or the newer ASP.NET 2.0.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 1.0 and 1.1 Basics section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old December 1st, 2006, 08:30 PM
Registered User
 
Join Date: Jul 2005
Location: Silver Spring, Maryland, USA.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default An error on Creating User with Web Site Tool

I am running ASP.NET 2.0 and trying to create User after I successfully tested the Provider and created membership role. But it continuously gives the following error: "An error was encountered. Please return to the previous page and try again."
 I tried so many ways but it still gives me an error. My web.config is as follows:

<?xml version="1.0"?>
<!--
    Note: As an alternative to hand editing this file you can use the
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in
    machine.config.comments usually located in
    \Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
  <appSettings>
    <add key="CartPersistDays" value="10" />
    <add key="MailServer" value="SMTP" />
    <add key="EnableErrorLogEmail" value="false" />
    <add key="ErrorLogEmail" value="name200@yahoo.com" />
    <add key="ProductsPerPage" value="6" />
    <add key="ProductDescriptionLength" value="60" />
    <add key="SiteName" value="Dandril" />
    <add key="CustomerServiceEmail" value="name200@yahoo.com" />
    <add key="OrderProcessorEmail" value="name200@yahoo.com" />
    <add key="SupplierEmail" value="name200@yahoo.com" />
  </appSettings>
  <connectionStrings>
    <remove name="LocalSqlServer" />
    <add name="LocalSqlServer" connectionString="Data Source=(local);Integrated Security=false;Initial Catalog=Dandrilling;User ID=famous;Password=infamous"
         providerName="System.Data.SqlClient" />
  </connectionStrings>
  <system.web>
    <authorization>
      <allow roles="Administrators" />
    </authorization>
    <profile>
      <properties>
        <add name="CreditCard" type="System.String" />
        <add name="Address1" type="System.String" />
        <add name="Address2" type="System.String" />
        <add name="City" type="System.String" />
        <add name="Region" type="System.String" />
        <add name="PostalCode" type="System.String" />
        <add name="Country" type="System.String" />
        <add name="ShippingRegion" type="System.String" />
        <add name="DayPhone" type="System.String" />
        <add name="EvePhone" type="System.String" />
        <add name="MobPhone" type="System.String" />
      </properties>
    </profile>

    <membership>
      <providers>
        <remove name="AspNetSqlMembershipProvider" />
        <add connectionStringName="LocalSqlServer"
          enablePasswordRetrieval="false"
          enablePasswordReset="true"
          requiresQuestionAndAnswer="true"
          applicationName="/"
          requiresUniqueEmail="false"
          passwordFormat="Hashed"
          maxInvalidPasswordAttempts="5"
          passwordAttemptWindow="10"
          minRequiredPasswordLength="6"
          minRequiredNonalphanumericCharacters="0"
          passwordStrengthRegularExpression=""
          name="AspNetSqlMembershipProvider"
          type="System.Web.Security.SqlMembershipProvider,#x D;#xA;
          System.Web,#xD;#xA;
          Version=2.0.0.0, Culture=neutral,#xD;#xA;
          PublicKeyToken=b03f5f7f11d50a3a" />
      </providers>
    </membership>

    <roleManager enabled="true" />
    <pages theme="Dandriltheme"/>
    <!--
            Set compilation debug="true" to insert debugging
            symbols into the compiled page. Because this
            affects performance, set this value to true only
            during development.
        -->
    <compilation debug="false"/>
    <!--
            The <authentication> section enables configuration
            of the security authentication mode used by
            ASP.NET to identify an incoming user.
        -->
    <authentication mode="Forms">
      <forms name="DandrilLogin" loginUrl="Login.aspx" timeout="60" />
    </authentication>

    <customErrors mode="RemoteOnly" defaultRedirect="error.aspx" />
    <!--
            The <customErrors> section enables configuration
            of what to do if/when an unhandled error occurs
            during the execution of a request. Specifically,
            it enables developers to configure html error pages
            to be displayed in place of a error stack trace.

        <customErrors mode="RemoteOnly" defaultRedirect="ErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm"/>
            <error statusCode="404" redirect="FileNotFound.htm"/>
        </customErrors>
        -->
    <globalization requestEncoding="utf-8" responseEncoding="utf-8"
                   culture="en-US"/>
  </system.web>
</configuration>

I hope some one will take a look at it and help me to find the error




Similar Threads
Thread Thread Starter Forum Replies Last Post
Error creating user on the administration tool r__gery ASP.NET 2.0 Basics 3 May 23rd, 2007 07:59 AM
ERROR using ASP.net Web Site Administration Tool erictamlam ASP.NET 2.0 Basics 0 April 5th, 2007 02:52 AM
ERROR using ASP.net Web Site Administration Tool erictamlam C# 2005 0 April 3rd, 2007 01:28 AM
Web Site Administration error on Create User fmegersa ASP.NET 2.0 Basics 1 December 11th, 2006 05:25 PM
ASP.NET 2.0 Web Site Admin error on Creating User fmegersa ASP.NET 2.0 Basics 0 December 1st, 2006 08:57 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.