Wrox Programmer Forums
Go Back   Wrox Programmer Forums > ASP.NET and ASP > ASP.NET 1.0 and 1.1 > ASP.NET 1.0 and 1.1 Professional
|
ASP.NET 1.0 and 1.1 Professional For advanced ASP.NET 1.x coders. Beginning-level questions will be redirected to other forums. NOT for "classic" ASP 3 or the newer ASP.NET 2.0 and 3.5
Welcome to the p2p.wrox.com Forums.

You are currently viewing the ASP.NET 1.0 and 1.1 Professional section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
 
Old October 16th, 2003, 08:06 PM
Authorized User
 
Join Date: Jun 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default Server Error in '/' Application - Method not found

I'm buidling the e-commerce Website from the book "Beginning ASP.NET E-Commerce."

I got my version of the application running just find on my local Web server, but when I upload my application to my Web Hosting Service, I am getting the following error.

Server Error in '/' Application.
Method not found: System.Collections.Specialized.NameValueCollection System.Web.HttpRequest.get_Params().
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.MissingMethodException: Method not found: System.Collections.Specialized.NameValueCollection System.Web.HttpRequest.get_Params().

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[MissingMethodException: Method not found: System.Collections.Specialized.NameValueCollection System.Web.HttpRequest.get_Params().]
   cactus_blues._default1.Page_Load(Object sender, EventArgs e) +0
   System.Web.UI.Control.OnLoad(EventArgs e) +67
   System.Web.UI.Control.LoadRecursive() +29
   System.Web.UI.Page.ProcessRequestMain() +724

Version Information: Microsoft .NET Framework Version:1.0.3705.288; ASP.NET Version:1.0.3705.288

Can anyone tell me what is happening here, and how to fix. Please give details because I am new at this.

Thanks.
 
Old October 27th, 2003, 03:27 PM
Registered User
 
Join Date: Oct 2003
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm guessing that your web host provider may be running a different version of the .net framework? You are running v1.0 and I'm guessing your host is running v1.1? Try upgrading to v1.1 SDK (make sure to install the redistributal package first), remove all references in your project file, and then re-add them (to make sure they are all referencing v1.1 components since v1.0 comps will still exist after installation). Rebuild and send to host again.






Similar Threads
Thread Thread Starter Forum Replies Last Post
Server Error in '/' Application - Method not found Jan_Ma ASP.NET 1.0 and 1.1 Basics 1 October 17th, 2003 10:26 AM
Server Error in '/' Application - Method not found Jan_Ma Classic ASP Basics 1 October 17th, 2003 09:01 AM
Server Error in '/' Application - Method not found Jan_Ma Classic ASP Professional 0 October 16th, 2003 08:07 PM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.