Wrox Programmer Forums
Go Back   Wrox Programmer Forums > .NET > Other .NET > Biztalk
| Search | Today's Posts | Mark Forums Read
Biztalk General discussion about Biztalk server.
Welcome to the p2p.wrox.com Forums.

You are currently viewing the Biztalk section of the Wrox Programmer to Programmer discussions. This is a community of software programmers and website developers including Wrox book authors and readers. New member registration was closed in 2019. New posts were shut off and the site was archived into this static format as of October 1, 2020. If you require technical support for a Wrox book please contact http://hub.wiley.com
  #1 (permalink)  
Old July 28th, 2006, 11:21 AM
Registered User
 
Join Date: Jul 2006
Location: , , .
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default EDI Unlisted Document version - Translation Failed


I have an EDI file Document 996 for Format version 3020 (which is not supported by the BASE EDI Adapter out of the box:

ISA*00* *00* *01*043073964 *12*6082744330 *20051220*0604*U*00302*000003522*0*P*$
GS*CG*043073964*6082744330**0604*50006*X*003020
ST*996*500060001
BGF*855*OQ*96243
K3*7997100
SE*4*500060001
GE*1*50006
IEA*1*000003522

Note I am not using Covast. When I use the Base EDI Adapter to pick up this instance it fails in the translation from EDI to XML phase. I keep getting the error from HAT – Error(30) Translation failed.

    Error encountered: ERROR (30), interchangenr 10012 :
    The document does not contain a required element. Contact the sender.source format: [5 00405 ,X12-4050]
    source document: [(unknown)]
    source segment: [data#0,def#1,tag=ISA ,name=Interchange Control Header]
    source element: [def#1,elm#1,comp#0,tag=9001,name=Authorization information qualifier], (msgnr:0 segnr:0)(line:1 pos:0 filepos:3)
    

    Error encountered: ERROR (30), interchangenr 10012 :
    The document does not contain a required element. Contact the sender.source format: [5 00405 ,X12-4050]
    source document: [(unknown)]
    source segment: [data#0,def#1,tag=ISA ,name=Interchange Control Header]
    source element: [def#3,elm#3,comp#0,tag=9003,name=Security information qualifier], (msgnr:0 segnr:0)(line:1 pos:0 filepos:3)

And so on - note only the elm# and the name keeps updated to reflect all 16 expected segments of the ISA interchange header. But as you can see from the sample the ISA interchange header is all there. Also note the Format version is 4050 and not the 3020 as it should be. And yes I have followed all the points in KB article
http://support.microsoft.com/kb/840113/en-us. (Set "Accept all unlisted documents" to "Yes" in the Receive Location configuration)

This error is obviously happening during the translation phase - when the EDI document is being translated into an XML Message. Any ideas?


Similar Threads
Thread Thread Starter Forum Replies Last Post
EDI nagaraju.gajula ASP.NET 2.0 Professional 2 December 16th, 2005 01:35 AM
EDI nagaraju.gajula ASP.NET 1.0 and 1.1 Basics 0 December 16th, 2005 12:55 AM
edi coding paul_jayakar J2EE 2 November 23rd, 2005 02:44 AM
Unlisted book and non-existent code mysorian Wrox Book Feedback 2 June 23rd, 2004 12:19 PM
EDI Integration using Java rajamsis J2EE 0 February 7th, 2004 05:31 AM





Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright (c) 2020 John Wiley & Sons, Inc.